Waterfall error while deepening river canal

Summary: On my map at the very top of the foothills is a lake. I thought I might have a waterfall system winding and cascading down the foothills to my town. Upon digging the first layer (using the mine tunnel tool) of the river, the water became too shallow over a distance for an impressive waterfall. I set a mining path along the river another 5 blocks deeper. The hearthlings started at the edge of the waterfall and were working their way back to the lake when this error popped up.


release-763 (x64)
stonehearth/components/water/water_component.lua:142: assertion failed!
stack traceback:
radiant/modules/common.lua:245: in function ‘report_traceback’
radiant/modules/common.lua:256: in function <radiant/modules/common.lua:250>
[C]: in function ‘assert’
stonehearth/components/water/water_component.lua:142: in function ‘add_water’
…arth/services/server/hydrology/hydrology_service.lua:964: in function ‘add_water’
…arth/services/server/hydrology/hydrology_service.lua:568: in function ‘_process_unlinked_waterfalls’
…arth/services/server/hydrology/hydrology_service.lua:395: in function ‘_on_tick’
…arth/services/server/hydrology/hydrology_service.lua:54: in function ‘fn’
radiant/controllers/nonpersistent_timer.lua:56: in function ‘fire’
radiant/controllers/time_tracker_controller.lua:86: in function <radiant/controllers/time_tracker_controller.lua:86>
[C]: in function ‘xpcall’
radiant/modules/common.lua:265: in function ‘xpcall’
radiant/controllers/time_tracker_controller.lua:86: in function ‘set_now’
…hearth/services/server/calendar/calendar_service.lua:421: in function ‘_on_event_loop’
…hearth/services/server/calendar/calendar_service.lua:46: in function ‘instance’
radiant/modules/events.lua:291: in function <radiant/modules/events.lua:285>
[C]: in function ‘xpcall’
radiant/modules/common.lua:265: in function ‘xpcall’
radiant/modules/events.lua:285: in function ‘trigger’
radiant/modules/events.lua:398: in function ‘_trigger_gameloop’
radiant/modules/events.lua:446: in function ‘_update’
radiant/server.lua:61: in function <radiant/server.lua:58>

Steps to reproduce:

  1. Start with a lake a long ways from a foothill’s edge.
  2. Dig one (x5 block deep) canal to serve as a long river to the foothill’s edge.
  3. Set a mining path for another (x5 blocks deep) within that same canal
  4. Set a mining path under the waterfall to clear any rough edges (try to make the foothill’s edge flush or straight). Place a ladder close to the waterfall opening
  5. If hearthlings set to work around the waterfall opening and work back along the canal, they will appear to be digging away under the shallow water

Expected Results: Expected to see water cascading as the miners worked

Actual Results: Water flow over any of the edges stopped and an error was produced

Notes: I have not tried to troubleshoot this error at all, so it is entirely possible that this error will be cleared upon refreshing the game.

Also note: If multiple errors appear, errors on pages 1 and 2 are old and unrelated to this water error.

Game File: waterfall-error-canal.zip (9.6 MB)

Version Number and Mods in use: a22.5r763
No mods (default rayya’s children and debugging tools)

System Information: Win 8.1 x64, AMD A10-4600M APU, 12.0 GB ram, Radeon HD Graphics 2.30 GHz, display adapter: amd Radeon HD 7660G (4.3.12618 compatibility profile context


I know this isnt what your post is about, but is there a way to make infinite water pools?

There will be, per @albert. It’s a water system roadmap item.

1 Like