Undefined sorting error

Trying to resort my items into containers. I received this message.

release-537 (x64)
Uncaught TypeError: Cannot read property 'sortable' of undefined
TypeError: Cannot read property 'sortable' of undefined
    at App.StonehearthTeamCrafterView.App.View.extend._buildOrderList (http://radiant/stonehearth/ui/game/show_workshop/show_team_workshop.js:853:40)
    at App.StonehearthTeamCrafterView.App.View.extend._build_workshop_ui (http://radiant/stonehearth/ui/game/show_workshop/show_team_workshop.js:442:12)
    at DeferredActionQueues.invoke (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:679:18)
    at Object.DeferredActionQueues.flush (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:749:15)
    at Object.Backburner.end (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:135:27)
    at http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:521:20

*Steps to reproduce:

  1. I can not seem to reproduce this error. I have reloaded the game and followed the same steps and it works fine.

*Expected Results:
Hearthlings will gather resources and sort them to the proper containers.

*Actual Results:
The error message pop up but did not seem to break anything.

Version Number and Mods in use:
Alpha 15 (537)

System Information:
Operating System: Windows 10 Home 64-bit (10.0, Build 10586) (10586.th2_release_sec.160223-1728)
Language: English (Regional Setting: English)
System Manufacturer: ASUSTeK Computer INC.
System Model: CM6850
BIOS: BIOS Date: 02/05/10 19:13:52 Ver: 08.00.10
Processor: Intel® Core™ i7-2600 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
Memory: 16384MB RAM
Available OS Memory: 16366MB RAM
Page File: 9568MB used, 23181MB available
Windows Dir: C:\WINDOWS
DirectX Version: 12
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.10586.0000 64bit Unicode

Card name: NVIDIA GeForce GTX 970
Manufacturer: NVIDIA
Chip type: GeForce GTX 970
DAC type: Integrated RAMDAC
Device Type: Full Device
Device Key: Enum\PCI\VEN_10DE&DEV_13C2&SUBSYS_39793842&REV_A1
Display Memory: 12190 MB
Dedicated Memory: 4007 MB
Shared Memory: 8182 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
Driver File Version: 10.18.0013.6451 (English)
Driver Version:
DDI Version: 12
Feature Levels: 12.1,12.0,11.1,11.0,10.1,10.0,9.3,9.2,9.1
Driver Model: WDDM 2.0
Graphics Preemption: DMA

1 Like

Are you getting this error constantly or just one time? If multiple times even after save/restart i would suggest pulling out the mods 1 by 1 until the issue is not appearing anymore.

You have allot of mods (very nice list) Perhaps one of them is not agreeing with the latest unstable branch version or may need an update. Just trowing some idea’s into the forum to maby help localise the issue.

1 Like

I’m getting this pretty similar error every time I try to open the weavers menue from the show workshop button of my weaver-hearthling:

release-537 (x64)Uncaught Error: cannot call methods on sortable prior to initialization; attempted to call method 'destroy'Error: cannot call methods on sortable prior to initialization; attempted to call method 'destroy'
    at Function.jQuery.extend.error (http://radiant/stonehearth/ui/root/js/libs/jquery-1.10.2.js:516:9)
    at HTMLDivElement.<anonymous> (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:487:15)
    at Function.jQuery.extend.each (http://radiant/stonehearth/ui/root/js/libs/jquery-1.10.2.js:657:23)
    at jQuery.fn.jQuery.each (http://radiant/stonehearth/ui/root/js/libs/jquery-1.10.2.js:266:17)
    at $.fn.(anonymous function) [as sortable] (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:483:9)
    at App.StonehearthTeamCrafterView.App.View.extend.willDestroyElement (http://radiant/stonehearth/ui/game/show_workshop/show_team_workshop.js:128:39)
    at apply (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:19673:32)
    at superWrapper [as willDestroyElement] (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:19247:15)
    at EmberObject.extend.trigger (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:40891:25)
    at apply (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:19675:27)
    at superWrapper [as trigger] (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:19247:15)

Also, the workshop can not be opened by clicking in the crafters menue. Potter works fine both ways. F5 or Save/Load doesn’t fix this.

I’ve got it once for the mason now but after another error and F5 because of UI not sowing the selected hearthlings it worked finally. The other error was:

release-537 (x64)Uncaught TypeError: Cannot read property 'element' of undefinedTypeError: Cannot read property 'element' of undefined
    at Object.merge.$ (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:41072:44)
    at CoreView.extend.$ (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:42540:34)
    at observer (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:8282:89)
    at Object.merge.invokeObserver (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:41117:18)
    at stateCheckedObserver (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:43217:29)
    at DeferredActionQueues.invoke (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:679:18)
    at Object.DeferredActionQueues.flush (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:749:15)
    at Object.Backburner.end (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:135:27)
    at http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:521:20

No this was the only time I received it. I had not seen this one before. I tried to recreate it but could not, which might be a good thing. I thought it was due to removing serval stockpile areas to make the workers stock items into containers.

If it happens again I will sort through the mods as it may have been one of those items.

I have only received errors on my crafters when I was reordering the build list. I will see if I can recreate that one and see if the results are similar

Trying to eliminate possible issues here. @Thomas, do you have any mods installed?

No, alway without mods

1 Like

Great, thanks! Paging @yshan to see this next week…

I can add another info: Only happens for the weaver of Rayyas Children :slight_smile:

That’s really good info! The RC Weaver had UI related issues earlier in the A15 dev cycle, maybe something still lingering…