The Sword of my mod don't stay right in the hand

#1

Hi guys :smiley: i’m new here and i make models,i tried to make a mod and it go all fine. but one thing i don’t like the sword wasn’t in hearthling hand PS:I use MagicaVoxel not Qubicle and thats not for sword thats for all items i make :confused: so any one can help me?

and also happen in the newest version of stonehearth

#2

hey there @Mine_Tutorials welcome to the discourse :smile:

could you perhaps provide a screenshot? seeing as your new you wont be able to upload it directly to the discourse, but if you upload it to imgur.com ,or your preferred site, and provide the link, then i could emended it for you.

1 Like
#3

i go do right now okay

1 Like
#4

Hey here is the link for imgur Imgur: The magic of the Internet
http://i.imgur.com/OjBwRcK.png

and another shot here http://imgur.com/nsLdcK

2 Likes
#5

You most likely need to do model origin stuff
It’s very complicated and I’m not sure how to easily change the Axis point from MagicaVoxel. You’ll might need to find another program that lets you do it.

1 Like
#6

if i understood what you meant, it’s actually pretty easy to change, as there are a few handy dandy rotation/flip buttons in magicavoxel.

(sorry for the bad screenshot, i’m in a hurry :grimacing: )

2 Likes
#9

Not really haha. Those options only change the model location on the matrix, which is kinda not helpful in this situation.

@Mine_Tutorials I found a mostly easy way to do it. I’ll make a small tutorial as soon as I finish getting the pictures together.

2 Likes
#10

sorry it’s not a short tutorial. I hate leaving stuff out.

Anyway. @Mine_Tutorials you seem to have the rotation and direction the weapon should face, that’s good.

The steps to get it centered are pretty easy, you just need to download another program.

1. Download Voxelshop Link here.
2. Create your item in MagicaVoxel and it will come out like this.

The next picture shows various options you use to help.
In the bottom right click to enable Frame to show the matrix box thing.
In the upper right click Shrink Size to shrink the size of the matrix to fit your object (this will help later. You can also manually change the numbers to the left of the button to change the size.)

4. Export your model as a qb
5. Open Voxelshop and Import your model and it will appear as like this next picture.
Mine may look different because I messed up the window arrangement
It may be hard to see but your goal is to put the center of the model where the black crosshairs are.
6. Select everything by pressing Ctrl A or find the Select button and highlight everything.
7. Drag the object with the mouse to the center . Use the various camera modes on the left to help you.

The following picture shows the centered model.
Note the middle right.
8. Click on “Layer (0)” and delete it with the button below it.

If the model goes outside the box, that’s completely fine.
9. Export your newly centered object. Make sure Compression and Bounding Box are unchecked.

10. Do all that json stuff.

3 Likes
8BitCrab's mods: "More Gold". V3.1 released, gold deposits and heroes swords!
Position of a weapon
BATTLEPUS! and Heimerdingers Qubicle Creations
Forge is not enough SH-ish
How do I centre models produced in MagicaVoxel?
[MOD] Locks of Many Colours:Version 4 now available! [A16]
Armor problem - modding new shield
Teach me how to SMOD
#11

It Worked Thx You are Awesome

1 Like
#13

excuse the slight necro of this thread

thanks so much for the tutorial on how to center weapons and such @PegLeg, it was very helpful/informative and has allowed me to actually have a mod worthy of V1 release :smile:

#14

You are using Magica Voxel too?

#15

indeed i am, never could get the hang of the controls in qubicle, so i never purchased it.

#16

Necroing this thread because I just can’t get Voxelshop to center the item. It looks like this:

Yet ingame it looks like this:

Not showing up in the placement menu either:

Anyone around who used Magica Voxel and Voxelshop recently?

#17

If you made the object positioned in the center of VoxelShop, and exported with the origin set to 0, then it should be centered in the game, unless your json file for that object is shifting its position.
You can also change the size of that voxelshop grid to have it matching the object size, making it easier to see if it is centered or not.

For it to show in the menu it must have a correct image and stockpile tags.

#18

I see. I just replaced the piggy bank from the startermod.
The json looks like this:

Summary

{
“type”: “entity”,
“mixins” : “file(piggy_bank_ghost.json)”,
“components” : {
“stonehearth:entity_forms” : {
“iconic_form” : “file(piggy_bank_iconic.json)”,
“ghost_form” : “file(piggy_bank_ghost.json)”,
“placeable_on_ground” : true
},
“region_collision_shape” : {
“region”: [
{
“min” : { “x” : 0, “y” : 0, “z” : 0 },
“max” : { “x” : 1, “y” : 0.4, “z” : 1 }
}
]
}
},
“entity_data” : {
“stonehearth:net_worth” : {
“value_in_gold” : 10,
“rarity” : “common”,
“shop_info” : {
“buyable” : false,
“sellable” : true,
“shopkeeper_level” : 1,
“shopkeeper_type” : “caravan”
}
}
}
}

Other than region_collision_shape there’s nothing that looks like it could lead to some off-centering. Tried to set everything to 0 (no clue what I’m doing) but that didn’t work.

At least it showed up in the menu after I issued a declaration and named the village.

#19

Check this. When a file has this “mixins”, it is importing the contents of another. So it means this object has more code in other places. Usually those positions code are left in the ghost, so both the ghost (the transparent object marking where it will be placed) and the object itself will have the same position, and you will not need to set it in two files

1 Like
#20

Alright, the problems seem to be tied to Magica Voxel’s export options:

If I check “Use bounding box as matrix” the item will be centered. But it looks like the center is actually a kinght’s move away. Unfortunately I don’t see any bounding box options that I could set to 31 41 31. Does Quibcle’s export work better? I’m willing to fork out money just to avoid spending more time.
Plus I’m not sure if the settings in the ghost.json are correct now. So there are multiple options that I would usually change one by one but it’s driving me insane right now.

#21

To change the size of the bounding box in voxelshop it’s here:
image

Click on the tiny arrow under the icon.

1 Like
#22

You need to mark the “use origin as zero”. Without it, the software will only consider 1 quarter of the field, that is why your model is moved.

1 Like
#23

Oh my. Why does it say “Un-check for Stonehearth” then? Probably a reason for it that just doesn’t apply in this case.