Scaffolting issue

playing fresh game and all, big structure had this error 2 times now
Steps to reproduce:

  1. big building
  2. let them build it
  3. watch people getting stuck and errors popping up

Expected Results:
no errors
Actual Results:
allot of errors but the game keeps playing and building keeps being worked on

release-687 (x64)[M]stonehearth/services/server/build/ladder_builder.lua:281: assertion failed!stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'assert’
stonehearth/services/server/build/ladder_builder.lua:281: in function '_get_climb_to’
stonehearth/services/server/build/ladder_builder.lua:297: in function '_update_build_mode’
stonehearth/services/server/build/ladder_builder.lua:181: in function 'add_point’
stonehearth/services/server/build/ladder_manager.lua:49: in function 'request_ladder_to’
stonehearth/services/server/build/build_service.lua:1502: in function 'request_ladder_to’
stonehearth/components/scaffolding/scaffolding.lua:526: in function 'request_ladder’
stonehearth/components/scaffolding/scaffolding.lua:571: in function 'request_ladder_to’
stonehearth/components/scaffolding/scaffolding.lua:619: in function '_update_ladders’
stonehearth/components/scaffolding/scaffolding.lua:310: in function ‘recalculate_scaffolding_blueprint’
…hearth/services/server/build/scaffolding_manager.lua:289: in function ‘_process_changes’
…hearth/services/server/build/scaffolding_manager.lua:279: in function 'obj’
radiant/modules/events.lua:83: in function 'instance’
radiant/modules/events.lua:291: in function <radiant/modules/events.lua:285>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:285: in function 'trigger’
radiant/modules/events.lua:398: in function '_trigger_gameloop’
radiant/modules/events.lua:446: in function '_update’
radiant/server.lua:61: in function <radiant/server.lua:58>

Version Number and Mods in use:
release 687 with terrain color mod, halloween mod and archipelago biome
System Information:

Hi @Doc_Brano, could you upload the savefile?

The issue has fixed it self. I do believe i have the cause of this error. My citizens want to build scaffolting underwater what takes more time. However some citizens tasked with building dont want to 'wait for scaffolting and start laying the bottom and walls. The citizens then gets stuck. Another part is that the citizens want to place a ladder down to get to the highest point but that interfeares with the idea of having scaffolting there. (5.4 MB)

1 Like

it seems they have decided that this massive wall is too much for them and stopped constructing it. I would have insta build it if it did not make the entire game freeze up. Can still build after it but no saving, no citizens walking around and no ui refresh

oke i restarted the map, placed down a small amount of the original wall. They did not want to continue any further.

Thinking a ladder would maby jump start the construction again i ordered the placing of one. Notice in the above pic they contructed a slab floor without issue but as soon as i ordered a ladder the went crazy about the scaffolting needed to be placed :frowning:

1 Like