[NaB] [Dev 2620] Debug Tools UI error

I downloaded the debug tools as I am trying to learn some rudimentary modding, and unfortunate the functionality I would like to use most, the item dropper, doesn’t appear to work for me.

The error:

develop-2620 (x64)
Uncaught TypeError: object is not a function
TypeError: object is not a function
at .widget._search (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:6214:8) at null._search (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:401:25) at .widget.search (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:6206:15)
at null.search (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:401:25)
at null. (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:6187:10)
at handlerProxy (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:730:6)

I seem to get one instance screen of this per character I type in the item dropper and I do not seem to be able to generate any items, I’ve tried with a wide range of base game items.

Thanks in advance for any possible help!

Hi @Cucaniensis, and welcome to the discourse!

I’m not sure what causes this error; I’m merely curious about something: what did you write in the item dropper?

Bear in mind that it only accepts a mod’s alias to spawn an item, in the format of

1 Like

Hello @Drotten ! Thank you! :smile:

I have tried things like stonehearth:oak_log, and stonehearth:fire_pit. They should work right?

The UI error would already show up as soon as I would type the s of stonehearth, at any rate :confused:

Those won’t work I’m afraid, when I say write the item’s alias I mean the entire alias. oak log has the alias “resources:wood:oak_log” so you’d then write stonehearth:resources:wood:oak_log to get the log (the fire pit has “decoration:firepit” as its alias).

You can find all the aliases for stonehearth in its manifest, so you should really take a look in there if you’re looking for a specific item. :wink:

Thinking of it some more, did you get the latest version? It has a item dropper now. For example, when you want an oak log you’d just type in oak_log (for instance) and the item dropper will give you a list of suggestions that matches the text!

1 Like

Right! Cheers for pointing that out! :smile:

So far I know I have the most recent version, that’s to say I got the version that’s on github right now. I have tried to delete the mod and redownload it today, which didn’t the fix the errors.

It’s probably relevant that the other tools do seem to function, it’s just the item dropper that prompts these errors.

I just tried with the correct aliases aswell, and I still get the error for every character typed, and no item spawns.

Hmm, that’s odd to say the least. You might want to try a complete reinstall of the game and see if that works out (i.e. remove the entire Stonehearth folder manually as Steam doesn’t remove everything, though that’s assuming you’re not just using the installer from Humble Bundle).

Just removed the stonehearth folder (manually) and then reinstalled (via Steam), and unfortunately the bug seems to persist :confused:

Then methinks I should page @yshan to see if she has any ideas.

1 Like

what are you trying to “spawn”, and is it from a mod?

Since I removed all the game files and reinstalled the game the debug tools are also the only mod I currently have installed and since then I’ve tried to “spawn” oak logs, fire pits and stone chairs.

The UI error itself happens each time I type anything in the debug tool’s “chatbox”. Not quite sure how to explain. The ratio of error screens is equal to each “type instance”. So if I slowly type letter after letter I will get one error screen per letter, if I type faster I’ll get the error screen as soon as I pause typing for a second. I hope that’s not too vague!

Is there any other information that I could provide that could be helpful?

could you provide a screenshot?

Providing a screenshot is something I can do! :smile:

(or for more detail: http://images.akamai.steamusercontent.com/ugc/392168636458856168/2F871AB5F93DE370DDF31F0C309F8ADD30C491A8/)

The UI error on the right side of the screen and on the left side of the screen appear to have the same text within them. The one of the left of the screen is actually a stack of the same error, and that UI error screen cannot be moved unlike the one on the right. Not sure if those details are relevant but I’d thought I’d mention them anyway.

hmm… strange, i’m not getting these errors when i just tested the new debug tools it just now… have you had any previous errors/problems in this save? if so, does a “clean” save have different results?

By clean save do you mean a fresh new game? Because for that screenshot I started a new game, the bug is reliably there for each new game.

1 Like

yes i did…

[quote=“Cucaniensis, post:14, topic:16853”]
Because for that screenshot I started a new game, the bug is reliably there for each new game.
[/quote]well thats a problem… i have not a clue what clould be causing this, so im gong to page @Albert @yshan @sdee for you too see if they can be of better help then myself.

1 Like

Hi there!
Did you rename the debugtools_master folder to just "debugtools"
I got this to happen if the debugtools mod folder is named wrong.



Well don’t I feel stupid and inept now… Changing the name worked!

Thank you @Drotten, @8BitCrab and @yshan for your time and help! :smile:

1 Like

I’ve also added an assert to the debugtools mod that will show up if the folder is named wrong. People run into this a lot, so don’t sweat it. XD