Issue with Talisman in my mod [Solved]

Hello everyone! I am new to coding and wanted to start by modding Stonehearth because I love it so much. I had an idea for what a Magmasmith class would look like, since the devs decided they would cut it from the final version. I’m able to get the manifest working and load the mod into the game, but when I load in I get this error:

release-880 (x64)[M]
@stonehearth/services/server/job/job_info_controller.lua:304: Crafter job stonehearth:jobs:blacksmith has a recipe named “tools:magmasmith_hammer” that produces an item not in the manifest magmasmith_mod:magmasmith:talisman
stack traceback:
[C]: in function ‘report_error’
radiant/modules/commons.lua:256: in function ‘verify’
…nehearth/services/server/job/job_info_controller.lua:304: in function ‘_initialize_recipe_data’
…nehearth/services/server/job/job_info_controller.lua:285: in function ‘_build_craftable_recipe_list’
…nehearth/services/server/job/job_info_controller.lua:119: in function <…nehearth/services/server/job/job_info_controller.lua:77>

I’ve mixed the recipe into the blacksmith and added an alias for the talisman “magmasmith:talisman”: “file(jobs/magmasmith/magmasmith_hammer/magmasmith_hammer_talisman.json)”,

everything that I have done seems to be pointing to the correct locations, however the item does not appear in game and I cannot spawn it with debug tools. I can’t seem to locate the problem. I will link my mod if it helps! (929.4 KB)


1 Like

In your manifest, change the mod namespace to lowercase. Use only lowercase to avoid confusion.

What happened is that you specify it as Mag… but the recipe is trying to spawn a mag…

Just a heads up, ACE - Authorized Community Expansion Project is working on a Magmasmith also, as a Dwarven-kingdom exclusive upgrade to the Blacksmith. You’re welcome to join the project or continue making your own version.

As for your error, magmasmith_hammer_recipe.json is including magamsmith_mod: in the product alias, when you shouldn’t be specifying your mod’s namespace in your own aliases.

That is incorrect. You need the namespace, else every single alias would have to be unique. Two different mods would not be able to have the same alias, like decoration:totem. I edited my post above, all you need is to correctly call the mod namespace, case sensitive.

1 Like

One capital letter! LOL! Gotta love coding. Thank you both for the help! @paulthegreat Thanks for the heads up, I am not a very skilled modder so I didn’t really want to volunteer for that project because IDK how much help I can really be. Hopefully our mods can coexist or maybe merge one day.

Whoops, I thought when referencing aliases within your own mod, that’s where it looked first. A sort of “scope” thing.

@BrunoSupremo, So I made the change as you suggested, but I am getting the exact same error. Any thing e;se that may be wrong? I’m out of ideas.

The only thing I did was open the manifest and change

Opened the game and it was there, although the image was not show in the crafting recipe, probably a wrong path

Strangely enough, the item does exist when i search for it in debug tools and I am able to create it, but the error message still appeared for me upon loading. I’ll keep tinkering until I get it right. Thanks for the help!