How can i destroy a finished building?

How can i destroy this building?

I tried to destroy a finished building in latest alpha 11 and I couldn’t do it, so I assume that the ability to destroy buildings is still not into the game. However, I know that devs are implementing it, it was shown on a livestream.

1 Like

I found a idea. Open console click on what I want to delete and write “destroy” on console. It’s work :smiley:


:laughing: Yes! Of course that works!
If you don’t mind cheating for the moment…


strange, awhile ago that would only delete singular parts of the building… so i had to use destroy for each wall, window, door, etc.

If you get into your “Build Custom” then click on then building you want to destroy, it will pop into the build window. If you click “finished editing” and then “remove building” it usually starts the deconstruction process. I’ve never successfully completely deconstructed an entire building but they certainly do try lol. I use it on multi-level buildings that corrupt during the build process so the workers abandon it. It seems to depend on the complexity of your building project and whether you keep an eye on all the workers that will get trapped on floating blocks (build lots of ladders to get them down).


i mean…
i can try to delete some building but with alot of gliches
they can add delete option ? like buldozer or somthing ?

You can insta-delete building by clicking on them, hitting CTRL C, and then typing destroy in the console.

tnx for help !!!

by the way…
still cant fix this glich… the game still stuck after i try to build roof up to roof like i uploaded to youtube last week…