Game Crashes upon startup (Lavasoft Ad-Aware)

I just bought the game last night, it crashed out after opening it i deleted it from computer not the steam uninstall. I let it re-download last night tried it again this morning and it still didn’t work. Spent about an hour reading about how to fix it from reinstall to up-date drivers. I did notice that people brought up 64bit systems have problems running the game. Yet the only thing I found out is that I have to get the game to open and run to change it to 32bit.

System Specs:
Operation system: Windows 10 Pro (64bit operating system)
Ram: 8 gigs
Video card: Nvidia GeForce GTX 540 (just updated it this morning via website)
Processor: AMD Phenom™ X4 965 processor 3.40 GHz

Here is my Stonehearth Log file aswell PAINkilers Stonehearth Log -

Im going to keep searching but I hope someone can help me with a fix. I’ve been wanting to buy this game for a few months now and rather disappointed that I crashes the second I open it.

1 Like

hey there @PAINkiler welcome to the discourse :smile:

seeing as you read a lot of stuff last night, i’m assuming you checked this thread,

[quote=“PAINkiler, post:1, topic:16042”]
I have to get the game to open and run to change it to 32bit.
[/quote]luckily that isnt true, instead you can go to your user_settings.json located in the stonehearth folder, then just change "force_32_bit" : false into true and it will run the 32-bit version.

hope that helps

edit: also i’ll just page @Albert so he can check the .log out.

1 Like

@PAINkiler - Welcome to the forum! The crash is in LavasoftTcpService64.dll. Lavasoft Ad-Aware is known to crash Stonehearth by injecting code into our dlls. Try disabling it and see if it runs (you may need to disable both client and server programs).


I didnt see that thread so ill go threw it right now. I do not have a “force_32_bit” : line in the user_settings.json file so i added the line and only got a error box telling me the coding is this file is wrong. so i deleted back out and now its back to what it was doing before. Opens music starts and crashes.

@Albert I opened my task manager and force closed all my lavasoft and ad-aware programs. Started the game and now i get 10-15 seconds of music with a black screen and then it crashes out.

Well, that’s progress… Ok, lets see the new stonehearth.log.

1 Like

hmm… could you upload a copy of what yours looks like?

I went ahead and just un-installed Adaware and the web companion and game is now working.

here is my log file if you still want to see it

@8BitCrab untill now since the game opened this time it only had the “user_id” line. now it has all this

“user_id” : “8b5ddbfc-518d-11e5-9e7e-e03f49a233b1”,
“renderer” : {
“run_once” : true,
“use_high_quality” : true,
“enable_ssao” : true,
“enable_shadows” : true,
“msaa_samples” : 1,
“shadow_quality” : 4,
“max_lights” : 50,
“enable_vsync” : false,
“enable_fullscreen” : false,
“screen_width” : 1764,
“screen_height” : 965,
“draw_distance” : 1000,
“last_window_x” : 0,
“last_window_y” : 0,
“last_screen_x” : 16,
“last_screen_y” : 62

1 Like

so then it was adaware, strange that it still stopped the game from running when you first disabled it…

So i haven’t played in since before update 12 so I went to play today and im back to crashing on startup. I still have Lavasoft Ad-Aware uninstalled. I did have AnitVir installed but uninstalling it didn’t help, My system specs are still the same as they were 2 months ago. I uninstalled the game and reinstalled it to see if that would fix it. I read the new post about running it in windows 8 then 7 if that didn’t work. I tryed both with no luck. So here is my log file hope that someone smarter then me can help me play again

my log file : logfile -

hey there @PAINkiler, sorry to hear that the game isn’t working again :hushed:

well thats definitely not me :wink: so i’ll page @Albert for this.

Thanks @8BitCrab hope we can find a fix again… since i posted i uninstalled 2 times and updated video card. Still no luck.

Hey there @PAINkiler, do you have your crash.dmp file? It would be located in the same folder as you stonehearth.log file. Can you upload it here?

I do @jomaxro but i dont know what do i use to send it? or should i just upload it somewhere like google docs?

If it is too big too upload directly (>3 MB), then yes, Google Docs or the like is your best bet!

1 Like

i tryed to add it directly and its unsupported file. and when i uploaded it to google docs it just keeps telling me no preview and to download it

try putting it into a .zip and then upload it. (24.6 KB)

thanks @8BitCrab zip file worked

here you go @jomaxro hope you understand it better then i did

1 Like

It’s still LavasoftTcpService64.dll. This thing can be a pain to remove sometimes. @Froggy had some good advice at the end of this thread:

Anyone else have any suggestions for him?

1 Like

@Albert i couldn’t find that file that you said any where on the pc so i read the artical didnt have any lavasoft installed anymore so i just deleted the folder, reset came back still didnt work so i googled “how to get uninstall” the file name it had sent me to a site to download adwcleaner program and i ran that and it just deleted a ton of stuff from reg files and game loaded to main screen after that. Thanks again for the help.

1 Like