Error message attempting to open workshop with character sheet open

Summary: When I attempted to open the weaver’s workshop window with her character info sheet still open, I got an error message (and nothing else happened). From then on, whenever I tried to open the workshop, even after I had manually closed the character info, I got an error message again (slightly different one, see under attachments). Save/load fixed this issue.

Steps to reproduce:

  • Have a crafter (I expect carpenter will work the same as weaver, but have not tried);
  • Build their workshop;
  • Open their character sheet;
  • Attempt to open the workshop with the character sheet still open.

11:03 attempt to open workshop the first time, error message pops up.
11:09 attempt to open it again after closing character sheet, different error message.
11:14 also does not work when opening from workbench.
11:42 got another error message opening someone else’s character sheet (reference to workbench in error message so presumably related).
14:08 effect remains.
14:14 save/load.
14:41 attempt again (from workbench), workshop window opens.

Versions and mods: No mods, latest release version in Steam at the time of writing, version 0.1.0 (release 166) according to the title screen.

System information:
OS: Windows 8 Pro 64 bits (6.2, build 9200)
Processor: Intel® Core™ i5-3450 CPU @ 3.10GHz (4 CPUs), ~3.5GHz
Memory: 8192MB RAM
DirectX-version: DirectX 11
Graphics card: NVIDIA GeForce GTX 660


I can confirm this bug.

1 Like