Error message and black screen (Solved!)


When I hit play from the steam store the game window pops up and an error popup comes up immediately along side the game. When I click OK, the game’s screen goes solid black and just sits there doing nothing.

I thought it was maybe mods being out of date, so I removed them from the mods folder. Now when I click play from the steam, it says ‘Running’ in steam for about 10 seconds, nothing happens during this time, and then it goes away and nothing loads.

Error message:


2016-07-18 09:30:09.360914 | server | 1 | app | Stonehearth Version (x64)
2016-07-18 09:30:09.361897 | server | 1 | core.config | user id is c279a66c-dd69-11e5-8a0e-34de1a06922a
2016-07-18 09:30:09.361897 | server | 1 | core.config | session id is bf66f1ae-4ceb-11e6-a645-34de1a06922a
2016-07-18 09:30:09.362987 | server | 0 | core.system | Initializing crash reporter
2016-07-18 09:30:09.877440 | server | 0 | | lua jit is disabled
2016-07-18 09:30:09.877440 | server | 1 | resources | Modules are verified pristine.
2016-07-18 09:30:09.879441 | server | 1 | app | Running Stonehearth server on port 57585
2016-07-18 09:30:09.879441 | client | 1 | renderer.renderer | Initializing OpenGL
2016-07-18 09:30:09.879441 | server | 0 | physics.navgrid | subspace pathfinder is enabled
2016-07-18 09:30:09.894457 | client | 1 | renderer.renderer | Determining window placement
2016-07-18 09:30:09.894457 | client | 1 | renderer.renderer | Selecting monitor at 671, 76
2016-07-18 09:30:09.894457 | client | 1 | renderer.renderer | Creating OpenGL Window
2016-07-18 09:30:09.909485 | server | 1 | resources | error looking for manifest in radiant: invalid file path ‘radiant/manifest.json’.
2016-07-18 09:30:09.909485 | server | 0 | lua.code | lua panic. forcing application exit
2016-07-18 09:30:09.910464 | server | 2 | lua.code | generating traceback…
2016-07-18 09:30:09.910464 | server | 0 | lua.code | – Script Error (lua) Begin -------------------------------
2016-07-18 09:30:09.910464 | server | 0 | lua.code | events
2016-07-18 09:30:09.910464 | server | 0 | lua.code | stack traceback:
2016-07-18 09:30:09.910464 | server | 0 | lua.code | – Lua Error End -------------------------------


(It doesn’t consider it a crash because I have to manually exit the game as it just sits on a blank screen)

Versions and Mods:

I don’t know how to find the # but it’s the latest Alpha 17 update. No mods anymore… I can post the list of what I had in before if it’s requested.

System Information:

[Please list Windows version (7, 8, 8.1, 10), video card (e.g. GTX 780), and monitor type (laptop panel or external monitor)

Windows 8.1, Intel graphics card, laptop panel

Have you attempted basic troubleshooting steps here:

Yes I have. It also used to work perfectly n this laptop, this is a dew development since trying out Alpha 17.


I haven’t tried uninstalling and reinstalling yet, but if nothing can be solved for a bit I’ll probably give that a try. Thank you so much for any help! I’m so excited to finally have time again to play, and to try out A17…!

you must update the used mods - cookmod, brewerymod or settlementdecormod

I removed the mods altogether, shouldn’t that not just load the game minus the mods? For example, say I have mod A B and C installed on A15, I update to A16 but mods A and B don’t have an update to A16 yet. Logically, I remove A and B and update C to A16.

This should work, otherwise players wouldn’t be able to play the new update if they’ve EVER had a mod that isn’t up-to-date. Please correct me if I’m wrong.

Either way I’m pretty sure it’s not the mods that are the issue… it’s now just not loading the game period with all mods removed entirely.

Thank you for the reply though!

ahhhhhh i have found it:

2016-07-18 09:30:09.909485 | server | 1 |
resources | error looking for manifest in radiant: invalid file path

do you have also removed radiant.smod?

there must be in the modfolder stonehearth.smod, radiant.smod and rayya_children.smod

There are absolutely no mods whatsoever anywhere in my stonehearth folder. :// I’ve removed absolutely everything I can find mod-related D=

Is manifest.json a mods-added file or a original file? I’m wondering if it was somehow deleted if its a original file? If that’s the case I may try uninstalling and reinstalling the game. :open_mouth:

I just glanced through my folder, I don’t have a /radiant folder at all. Hmm

I think you’ve done the equivalent of deleting the autoexec.bat and files of yesteryear. Reinstalling is probably your best bet now.

1 Like

Yeah, wonder how I managed that one. I rarely mess with the files other than adding and removing mods =A= Reinstalling… I’ll post if it worked or not.

Thank you :slight_smile:

1 Like

Alright, reinstalling worked!

I’m honestly at a loss for what happened! Anyway, thank you guys for the help! Now to start fresh as all my saves are gone (did that purposely, coulda saved them but wanted to be safe and didn’t have any I particularly cared for)

1 Like