Engine Error on loading game while tabbed out

As the the topic says, was loading up my saved game while tabbed out and when I tabbed back in this was showing. Also running the new pathfinder and AI.

Hope it helps!

develop-2630 (x64)
No matching overload found, candidates: void __add(lua_State*,Point3 const&,Point3 const&)
stack traceback:
radiant/modules/common.luac:46: in function <radiant/modules/common.luac:46>
[C]: ?
[C]: ?
radiant/modules/terrain.luac:121: in function ‘find_placement_point’
…resource_node/renewable_resource_node_component.luac:62: in function ‘spawn_resource’
…resource_node/renewable_resource_node_component.luac:89: in function ‘renew’
…resource_node/renewable_resource_node_component.luac:33: in function '_fn’
radiant/controllers/timer_controller.luac:33: in function 'fire’
radiant/controllers/time_tracker_controller.luac:9: in function <radiant/controllers/time_tracker_controller.luac:9>
[C]: in function 'xpcall’
radiant/controllers/time_tracker_controller.luac:9: in function ‘set_now’
…earth/services/server/calendar/calendar_service.luac:133: in function 'fn’
radiant/modules/events.luac:58: in function <radiant/modules/events.luac:57>
[C]: in function 'xpcall’
radiant/modules/events.luac:57: in function 'trigger’
radiant/modules/events.luac:78: in function '_trigger_gameloop’
radiant/modules/events.luac:87: in function '_update’
radiant/server.luac:19: in function <radiant/server.luac:17>

And while writing that post I got a 1 more while tabbed out:

develop-2630 (x64)
std::logic_error: 'invalid entity reference in get_standable_point’
stack traceback:
[C]: ?
[C]: in function 'get_standable_point’
radiant/modules/terrain.luac:51: in function ‘get_standable_point’
…spawn_region_finder/spawn_region_finder_service.luac:55: in function ‘try_spawn’
…spawn_region_finder/spawn_region_finder_service.luac:61: in function <…spawn_region_finder/spawn_region_finder_service.luac:56>

So I’m having several problems with my save now so I just decided to upload it.

The first engine error i posted pops up on every load and after a few mins there are 3 other errors.

I’m also having problems with no Poyos spawning anymore, I had the problem with to many Poyos so i salughtered a few so i had 1 left and last one just wouldnt pop any eggs so i slaughtered the last one and did the whole pen again but there is just no Poyos spawning anywhere.

Also having a major issue with my blacksmiths not doing anything blacksmith related anymore even tho alot of stuff is qued up. I’m not sure when this happend, I just noticed it.

Also alot of heartling idling even tho there are jobs but I dont know if there is a limit of how many hearthlings you can have on 1 job,

And last but not least, ALOT of stuttering and lag when its meal time cause they all do it at the same time, the patchfinder takes all the “umf”.

PC specs:

Win 7 Home
3770k i7
GTX 660 OC
Kingston Hypbeast 16GB 2400MHz
MB Asus P8 Z77-V LX2
Game is on a Kingston 240GB SSD

Thanks! I’ll take a look at the save game.

1 Like