Crash Release-766

crash-dmp_provided
a23r771

#1

Summary:
my game crashes at seemingly random times. after a while of playing the game will become unresponsive and then crash shortly after. but I am unable to find a pattern to the crash. then after it crashes and I open the game again the game has no sound so I have to close it and open it a couple of times until the sound comes back.
Steps to reproduce:

  1. play the game like how I do ( I assume something that I am doing is causing it to crash)

Expected Results:
no crash
Actual Results:
crash at random times
Notes:
can someone help me identify the sorce of the crash? because it seems to be random. i am unable to find a pattern
Attachments:
possibly something to do with this
release-766 (x64)[M]
…hearth/components/scaffolding/scaffolding_region.lua:1092: attempt to index field ‘_scaffolding_region’ (a nil value)
stack traceback:
radiant/modules/commons.lua:46: in function 'report_traceback’
radiant/modules/commons.lua:57: in function <radiant/modules/commons.lua:51>
…hearth/components/scaffolding/scaffolding_region.lua:1092: in function ‘_update_scaffolding_size’
…hearth/components/scaffolding/scaffolding_region.lua:499: in function 'fn’
radiant/modules/events.lua:288: in function <radiant/modules/events.lua:285>
[C]: in function 'xpcall’
radiant/modules/commons.lua:66: in function 'xpcall’
radiant/modules/events.lua:285: in function 'trigger’
radiant/modules/events.lua:370: in function '_fire_async_triggers’
radiant/modules/events.lua:445: in function '_update’
radiant/server.lua:62: in function <radiant/server.lua:59>
Version Number and Mods in use:
release-766


#2

Can you upload stonehearth.logand crash.dmp from after the crash? These files are located in the game install directory. The default Steam location is C:\Program Files (x86)\Steam\steamapps\common\Stonehearth.


#3

what about the crash.zip?crash.dmp (170.4 KB)


#4

Thanks for uploading that. I see it is a bug that has already been fixed and will be included in the next unstable release.


#5

ok when is the next unstable comming?


#6

When it’s ready.


#7

Is the crash fixed as of Release-771 and my game is crashing for a different reason? or is it still not fixed?


#8

We did a push to unstable on (I think) Monday the 18th, are you still getting your crash issue?


#9

The crash in that crash.dmp file should be fixed in release 771. The scaffolding error still exists, but it’s not prioritized for a fix since the whole building system is being replaced soon.


#10

crash.dmp (268.2 KB)
i got this crash in Relese-771


#11

That’s a different crash; something related to the UI (Chromium). Can’t debug it properly while out of office, but I’ll take another look after I’m back in January. Thanks for the report!


#12

Took a look at this, but still not super clear what’s wrong. How do you get this crash to happen? Do you have any custom changes to user_settings.json?


#13

is this the same crash that I am now getting in Release-779
crash.dmp (184.1 KB)


#14

I also go this
Sonehearth Assertion Failed
@max99x
this was a different time but it didn’t crash thought it was going to.