[Con] Windows XP not supported


#1

Making a new bug from this post.

Continuing the discussion from The Stonehearth Graphics Test Thread:


[Dup] Problem with launch
Stonehearth doesn't work on my window XP computer! HELP!
Stonehearth Won't Open?
The Stonehearth Graphics Test Thread
#2

Update: this seems to happen on all Windows XP machines.


#3

I figure this should get a bump for new users. Alpha 1 still has this same issue. In steam, when I press play nothing happens, but installing and running the humble bundle download version still gives this error.


#4

Don’t take this the wrong way, but should the developers really waste time with supporting an 13 year old operating system that have had it’s lifespan extended by companies not wanting to upgrade their applications?

I’d rather see a linux version of Stonehearth (for those of you still on XP that can’t afford a new license).


#5

I downloaded SH as soon as I saw it a few weeks ago, since it was on Steam early. And as I saw it properly released the other day, I races to Steam to update SH but alas, it doesn’t actually open. I’ve tried a couple of times, and even restarting my PC, but it simply won’t open. :(. Does it not work on XP or something?

Oh, and as a side-question, I donated $50 on Kickstarter all that time ago, and I’m just wondering where I can get my second key to give to my friend?

Cheers.


#6

Okay, thanks for the report, hwoever it should be posted over here


#7

I thought that was a fan-forum? And it’s not so much of a report, as a what’s the problem.


#8

Afraid Stonehearth doesn’t work on XP yet, I’ll move you over the right place :slight_smile:


#9

#10

**EDIT: ** Nevermind, I found it.

Thanks Geoffers. But about

Do you know how I might go about getting that key for my friend?


#11

Ah sorry, must have missed that part!

Check this image, at the bottom where it says Stonehaerth Gift Key - if you go to the Stonehearth page on your humble account you’ll find it there!


#12

okay so i downloaded stone hearth but when i try to launch it this window pops up (The procedure entry point RegGetValueA could not be located in the dynamic link library ADVAPI32.dll)…Help would be greatly appreciated


#13

Seems like something didn’t install… have you done it via the Humble Bundle installer or via Steam? :wink:


#14

the humble installer


#15

Maybe you don’t have something installed (like DirectX or other programs) to run Stonehearth. Steam always automatically installs everything you need, try it via Steam and let us know about the problem. Does it still exist then or did that fix it? :wink:


#16

okay so i tried to launch it via steam and it popped upon my task bar but disappeared and i tried again and again and then something popped up and said that it’s already running…?


#17

Okay guys, thanks for the feedback - however here is the official place to report bugs and where you will get developer feedback \ help, so it would be best if you reposted it there, thanks


#18

That’s strange. Try running it via the Humble Installer again as Steam might’ve installed required components for you now. :wink:


#19

so i reinstalled it and it said the same thing


#20

I can’t help you anymore. Do what @Sarhifigus and it probably will get fixed soon. :wink: