[Con] Unable to build after error occured while building road

Version: Stonehearth 0.10.0 (alpha_10_5 3) x64 build - Peaceful Game

System Info: Windows 7 64bit. AMD Phenom II X6 1100T. 12Gig memory. NVIDIA GeForce GTX 680.

Summary: Started playing on a new map, successfully placed and build templates for communal beds and dining hall then attempted to build a road. Successfully placed down planned and built first small section then an error occurred while planning the next section (refer to linked screenshots). Closed error and found I could not continue to plan (with stone texture I wanted selected, the moment I click in the world to place/plan the road piece, the piece fails and the texture is deselected). Since there have been a couple of issues with road building I decided to leave it and move onto another task, however I am now unable to plan or place any structures (including templates).

Impact: Game is now limited to generic/automatic hearthling tasks such as farming/mining/trapping etc.


UPDATE: Upon doing a full system restart, I am able to open my saved game and resume normal gameplay.


thanks for the follow-up… we’ll keep the report open for now, but please do let us know if the issue returns… :+1:

1 Like

Okay, played for a couple more hours today and it happened one more time. Same error as the first one, but I was able to just close down the game and restart it this time, rather than having to reset my system, which was nice.
Same conditions though, was trying to plan/build a section of road when the error popped up. Closed the error box and was then unable to build any more until I exited and reopened the game.
I have the feeling that the error popping up when it does is making the ‘brain’ spaz out so it thinks it’s still laying down the planned section of road to be built so it gets stuck on that, since you can only plan out one build at a time.
Not sure if that’s it (or if I’m even making sense). But yeah, this has happened twice over a period of approximately twelve hours of gameplay.

1 Like

I know this may be asking a lot, but if you can get a video recording of the steps to reproduce, that will be hugely valuable to TR.

From my own experience, I know that I’ve had errors when building and/or moving roads. They seem to be more complex, on average, than building slabs or (simple) buildings.

I just encountered this error too. I was placing individual blocks, then I tried the drag and drop block placement, and the game gave me an error that had this same effect on me. I don’t know what it means, but the report bug button gave me this link to copy: 8d455eea-271c-11e5-b665-8c89a50e70d3

Edit: after reinstalling C++ and restarting my computer, I still run into this issue. It tends to occur within a minute or two of custom building a house.

1 Like