[Con] Pure virtual function call error

is anyone else getting this bug its really annoying me i been waiting for the dev build for alpha 10 patiently and now i cant even play it please fix it Radiant,

1 Like

can you toss up a screenshot? anything in particular that leads up to this error?


I can confirm this.

Game then crashes.
Clean install, Win7 x64

I can confirm this aswell, same error as @KfrogCT.

thanks for the confirmations folks… [tagged]

and nothing leads up to this, it just happens on game load?

Hey there,

as the water comes I wanted to try it so when I want to create new world this happend:

Tried to download MV C++ but no.

same here ^^ all extras deactivated (x64 + high qual + lua jit) no firewall

from the stonehearth.log:
2015-Apr-23 08:45:40.665445 | client | 1 | renderer.render_info | could not load qubicle file: invalid file path ‘’.
2015-Apr-23 08:46:02.020674 | client | 1 | lua.code | unrecognized object type ‘boxed’ in json_to_lua!
2015-Apr-23 08:46:02.021678 | client | 1 | lua.code | unrecognized object type ‘boxed’ in json_to_lua!
2015-Apr-23 08:46:02.839714 | server | 1 | simulation.remote_client | started buffering client updates. (seq:259 ack:249)

Yes me the same :confused: I am so excited from the water that I cant wait

1 Like

Hey @lasiecz and @Wiese2007, sorry about the error. :frowning: Can you post your system stats? (OS version, graphics card, CPU, Memory, etc?)

Win 7 x64
Intel i7 3.40 GHz
AMD Radeon HD 7700

No prob @sdee and thank you like always for your great work :smiley:

Win8.1 X64
AMD Readon HD5700
AMD Phenom II X6 1045T

for more infos like always dxdiag or just ask^^

Same problem.

Win 8.1 x64
AMD Phenom II x4 965
Radeon HD7770 (x2)

I have the same problem.

Win 7 64bit
AMD FX-8320 Eight-core ~3,5GHz
AMD Radeon HD 7800 series

Funny to see all the ones posted here with a problem have a AMD Radeon HD series

yes it seems to happen as i load the game up it seems to be happening only on the hd series my friends can get on the game fine a couple are running R series and a couple are running Gtx series so it just seems to be the hd so if you could have a check Stephanie that would be a great help hope the team can get it sorted by tonight im really excited to play the new update ")

I agree. HD7900 Series here also.

Thanks so much for narrowing this down, everyone! It really, really helps :smiley:

Found and fixed on my machine; next update should work for everyone. Thanks for all the bug reports. I’ll try not to write anything too passive-aggressive about a certain video card vendor’s driver quality…


@not_owen_wilson, so what DOES happen when you write m = m * foo?


Let that be a lesson to you kids: never read from memory locations to which you’re storing!