Changed job for a hearthling, crafting page will not show up


Switched a worker hearthling to weaver. Weaver crafting panel will not open. Triggers an exception and prompts me to press F5 to refresh UI.

Steps to reproduce:

  1. Purshased spindle from trader when visited town.

  2. Switched hearthling from worker to Weaver.

  3. If cannot open weaver crafting page. Repeatedly clicking it does nothing.

  4. Opened another crafter page (potter) it works.

  5. Clicked another crafter (herbalist) it works.

  6. Clicked weaver again and it crashed the UI with following message:

     develop-2860 (x64)
     Uncaught Error: cannot call methods on sortable prior to initialization; attempted to call method 'destroy'
     Error: cannot call methods on sortable prior to initialization; attempted to call method 'destroy'
     at Function.jQuery.extend.error (http://radiant/stonehearth/ui/root/js/libs/jquery-1.10.2.js:516:9)
     at HTMLDivElement.<anonymous> (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:487:15)
     at Function.jQuery.extend.each (http://radiant/stonehearth/ui/root/js/libs/jquery-1.10.2.js:657:23)
     at jQuery.fn.jQuery.each (http://radiant/stonehearth/ui/root/js/libs/jquery-1.10.2.js:266:17)
     at $.fn.( anonymous function ) as sortable (http://radiant/stonehearth/ui/root/js/libs/jquery-ui-1.10.3.js:483:9)
     at App.StonehearthTeamCrafterView.App.View.extend.willDestroyElement    (http://radiant/stonehearth/ui/game/show_workshop/show_team_workshop.js:128:39)
     at apply (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:19673:32)
     at superWrapper as willDestroyElement (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:19247:15)
     at EmberObject.extend.trigger (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:40891:25)
     at apply (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.js:19675:27)

Expected Results:

Weaver’s crafting panel opens and can be used.

Actual Results:

UI Crashed.


Unique uID: ff9a5946-c566-11e5-9539-448a5b886156


Sadly, there is nothing I can show beyond the error message in section “steps to reproduce” above.

Version Number and Mods in use:

No mods running on develop-2860(x64)

System Information:

Windows 10 (x64)
Radeon R7 370x 4gb gpu
16gb Ram
6core AMD FX 6300 ~ 3.5Ghz

Things I’ve tried after initially posting this

Change job back to worker for the weaver hearthling.
Noticed the weaver still shows as a crafting option in the crafting menu, even though I no longer have a weaver. See screenshot below.

As you see, list of hearthlings does not have a weaver, as I have switched job back to worker. However, the weaver craft still shows as selectable tile in the Crafters menu.

Fiddling with the crafters randomly will give me the previously mentioned UI error. No two times did the error poped up by doing the exact same thing. I did clicked rather abusively on the weaver icon in the crafters menu then clicked other crafting options that do open a panel, then clicked weaver like it’s hot, and sometimes doing this popped the UI error popup, not always. The result was the same all the time though, no weaver crafting panel opens.

Another thing I’ve tried. I have switched job back to worker and sold the spindle and bought a new one from merchant when available. The result was no different and I still couldn’t open the weaver crafts panel.

A post was merged into an existing topic: A15 | Cannot access weaver build menu