Cant update steam workshop mod, please help (Make sure manifest is valid before trying to update!)

cant update my steam mod, the button says upload, not update.

Steps to reproduce:

  1. make a steam workshop mod
  2. fiddle withe the insides, i may have accidentally subscribed and unsubscribed to my own mod

Expected Results:
update button still there.

Actual Results:
not update but upload there, the following error:

Version Number and Mods in use:
latest rickety

System Information:
win 7 64 bit

if you need any other info, let me know!

I try to access your mod through the workshop (with the ID from that popup), but either its visibility is set to private, or you might have deleted it accidentally. That would explain why the button says Upload and not Update.

Can you still see your mod if you browse your items in the workshop?
Have you messed with the Steam file ID?

If your mod was really deleted from the workshop, you’d need to create a new one from our UI, since that ID is invalid now. Is there any “Invalid Steam File ID” message in the Mods menu for your mod?

The message from that popup needs to be fixed, in any case.

1 Like

@Relyss I hid it so others wouldnt download a broken mod, its now unhidden again.
here, the link:

-havent messed with the id
-the id matches the code in the link above, so that checks out (judging from other game modding)

if you want to oggle at the mod yourself i can dropbox it no problem or something

Did you update your mod with the game open, or did you close the game and restarted it before trying to update it?

oh good one, mostly closed game, changed stuff, re started game. but i have also tried it the other way around after.

1 Like

if it helps: if i hit view file in workshop it gives this:

What’s that?

Could you try fixing your manifest before trying to upload it? There seems to be something wrong with it :thinking:

dont know whats wrong with it thought

“info” : {
“name” : “Vikingmod”,
“namespace” : “VikingmodW”,
“version” : 3,
“default_locale” : “en”,
“steam_file_id” : “1369569709”
“aliases” : {
“steel_axe” : “file(entities/steel_axe/steel_axe.json)”,
“wooden_round_shield” : “file(entities/wooden_round_shield/wooden_round_shield.json)”
“mixintos” : {
“stonehearth/jobs/blacksmith/recipes/recipes.json” : “file(jobs/blacksmith/recipes/recipes.json)”,
“stonehearth/jobs/carpenter/recipes/recipes.json” : “file(jobs/carpenter/recipes/recipes.json)”
“overrides” : {},
“components” : {},
“controllers” : {}

it has so little, i wouldnt know whats broken about it.
(two aliasses for two entities, two mixinto’s so the crafters know the recipies, and those lines work in my “local” version

You’re missing a comma before “overrides”

1 Like

@Relyss it was the bloody comma. everything works now.
(grammar is sometimes the bane of my existance it seems…)

well, now we know what your error message meant:
“sorry, your manifest is invalid, check for typo’s and missing comma’s!”

1 Like

Yeah, if the JSON has invalid syntax Steam won’t be able to parse it correctly. It reads the file id from the manifest so it needs to be valid.

1 Like