Building cannot be removed (2018)


#1

For another thread I created a simple tower, but it now has become unremovable, i.e. when I click the “trash” icon, nothing happends.

I already tried to use the console command (select building, open console with Ctrl+C, type “destroy”) as described in [Building cannot be removed], but it didn’t work; It is also unclear if I am doing it right, since selecting the building seems to require enabling build mode.

If I select any building in “Build” mode and then enter “destroy” in the console, all I get is

{
    "error": "lua runtime error"
}

Any idea what else I may try?

savegame.zip (6.7 MB)


#2

Try selecting the building, opening the lua console, switching to the client mode, and then type stonehearth.building:destroy_building_command()


#3

Possibly a stupid question, but how do I select a building?

Outside building mode, clicking a building does nothing and I get variable 'e' is not declared. Selecting the building in build mode, I still get the same error message.


#4

Presumably you don’t need to use e. Did the command as listed not work with the building selected in build mode?


#5

It didn’t have any effect at all, returning <nil> but doing nothing.


#6

After loading your savefile, I can confirm what you’re saying. Other buildings are still destructible. It seems that the building has been removed from the server service’s ._sv.buildings collection and so cannot be destroyed.

@linda, is there an easy way to destroy the building entity from the client side (like the radiant.entities.destroy_entity(...) that’s getting called by the server service), or pass the building entity from the client to the server from the console?


#7

I added the bugreport flag to the thread.


#8

I’ll take a look at the save


#9

Looks like something went really really wrong and the building got into an unrecoverable state :anguished:. Do you have a save from before this happened?


#10

Possible, but chances are it is so old, that the one stray attempt-building isn’t the bigger issue. I mean, it doesn’t look THAT ugly. If I tilt my head. :cry:

In the savegame another bug occurred however, that has more serious consequences: After removing several 20x20 stockpiles, hoping that the stuff would be relocated to my newly built mountain-cave storage, the items that had been stored in the stockpile zones are now being ignored by my hearthlings entirely. They will rather idle, than haul the items, and they cannot be selected with the Loot tool either. Selecting and destroy in the Ctrl+C console does work however.

Attachment as RAR, because it exceeds the 10MB limit as zip file.
savegame2.rar (6.3 MB)

On a related note, creating said storage room was a bit of a drag, because the containers default to “None” :slight_smile:


#11

Whether they default to None or All is a setting you can change in your game settings. I forget if there are other options for it.


#12

Did they start restocking it after you try reloading the game?


#13

Not when I tried yesterday anyway. I think I closed the game in between. Will report back when I am at home and tried again.

Update: Seems like they’ve found their taste for cleanup again. Seems like they’ve actually been held up by a large amount of overproduced farm and herding goods lying around, that I didn’t notice before.

Avoiding overstocking is a bit of an issue :-/


#14

Or not… Cleanup isn’t really progressing and the hearthlings are turning into messies.


#15

It sounds like you’re hitting performance issues and running into some idle hearthling problems. Can you try getting rid of excess items in your town that you aren’t using much?


#16

How would I go about this? A blanket-sale to the next merchant maybe?


#17

Playing on speed 1 also helps with performance, though I realize that can get annoying


#18

Maybe relevant: I had over 400 silkweed bundle, but none of them were showing up in in the “Sell” interface (as they had not been stocked).

I tried pausing all jobs to have them focus on hauling, but it didn’t help much. Most hearthlings would just idle, sleep and drink.


#19

I am running into a similar issue again (lack of hauling) on a new savegame.

It seems that everything breaks down the moment I try to transition to using containers, with containers standing empty all around, while stuff lying around mounts up on the fields.

Could it be that the hearthlings can’t decide which containers to use?


#20

It seems it got better, once I removed all containers, that were stacked on top of each other, though I can’t be quite sure if the problem actually has gone away.

Is there any way to get debug information about unreachable containers?