Builders Stay Idle!

Everyone but the farmers and footmen have stopped doing work. The only time anyone else does work is if it’s a Blacksmith, Carpenter, Weaver etc… My citizens just stand there idle until it’s time to eat. Then they stand idle in the house until it’s time to gather around the fire at night. Then they go back to the house to Sleep. The only thing they ever do anymore is cut down trees when I tell them to. When I make a new building they stop building it randomly even though I have five times more of the supplies than I actually need. After finishing the walls of a building after having to tell the to build it over and over again they stop. The roof never gets finished no matter how many times I tell the to build it, restart my game, or collect more supplies. Once in a blue moon they take down the scaffolding and then another citizen just puts it back up again as if they’re going to use it. Anytime I try to undeploy or move an Item they stand there idle as if there’s nothing to move.

This makes me want to quit so much but I can’t because this game is so good Dx

The problem might consist on what surrounds the house.
Is there any cliffs/mountains nearby?
Do they obstruct the building process?

I simply fixed it by building the building out in the open.

I think this is a common issue once your game gets too large, this exact thing happens to me once I get too many citizens or my town is too big. So I take a break then build a new town next week :smile:

1 Like

Yeah I think you’re right because once when I hit around 20 citizens it started getting worse and worse. When I start a new game everything works sort of fine.

1 Like

Nothing is necessarily in the way. The building is at least 3-4 blocks away from any other buildings, mountains, walls, or trees.

its day 3, we were building are second building, i needed more wood so i harvested some trees and then the workers stopped building. f3 ai reset isn’t working, save and load didn’t work. i only have the original seven citizens with one being a carpenter

the AI reset button is F5

still stuck unfortunatly

I think that’s for resetting the UI, not the AI.


f5 reset the logos on the screen

HAHAHA yes the logos. AKA the UI (User Interface)

crappy part is all my workers just went idle and there are only 8 of them… 1.5 structures…

I have 0 buildings because it wont let me design anything. It also wont let me place down the default buildings. Plus all the F’s don’t work with my idle workers either…

I think it has something to do with the wood in general. I was playing and i had a stockpile 12x10 almost full of wood and suddenly all my citizens became idle again. So I tried to make a new stockpile and delete the old one which worked for a day. The next it happened again. So, my curiosity got the better of me and i started to dig and found out that i had zero wood in my inventory even with a half full stockpile. Its almost as if the wood has only become visible to me. I think it has something to do with the presence of the wood in the stockpile and in the environment. To be honest, it be also linked to why they leave wood on top of buildings and in the middle of the table.

Hopefully this helps.

1 Like