[Bug] Moved goblin fire pit keeps spawning goblins


I just purchased the game a few days ago and I totally love it. I have however encountered a bug which is quite annoying;

I had quite a few goblin keeps popping up on the map early on, dealt with them without any problems, but I tried moving one of their fire pits, and although I successfully managed to do it, goblins kept on spawning afterwards. I then packed up their firepit, and now it seems to be totally missing.

The problem/bug I’ve encountered is that the ground exactly under where the original goblin fire pit was situated still has some strange texture and still spawns 3-5 goblins almost every night. It can’t be mined either and seems to be some part of the goblin spawning mechanics…

If anyone has any tips on how to get rid of it, that would be appreciated… I tried to reload the game, as this solves many other small issues the game has, but that was to no avail.

After this, I continued playing and have since ran into the golbin camps with wolves and annihilated them all, and have gotten the message that goblins should no longer be an issue.
Once buildings are destroyable/removable, that mechanic could maybe be used to remove those tiles that are spawning the goblins…
I’ve been dealing with a lot of mobs because of this, and I can keep all my hearthlings alive without too much effort, but I’ve also noted that my footmen barely gain any experience and take forever to level up. This might be intentional by Radiant, however…

Version: aplha 10_5_3 (64), no mods

1 Like

It is known that you aren’t supposed to be able to pick up the goblins fireplace and doing so will cause bad things to happen. If you don’t destroy the fireplace, then their stockpile won’t go away and their camp still exists. So they’ll respawn every night because of it. I’m not sure why you can still pick up the goblin fireplace after @Albert fixed one of the resulting bugs (your footmen tended to go insane and kill each other). I suspect vindictiveness.


I don’t remember how exactly I did it, but I did, so yeah …

Is there any way (through some kind of world editor, or by manually doing something) to change those tiles to normal grass tiles?

I’ve also done this.
I just selected the fireplace (Mystic fireplace or something like that), pressed the ->Move item button and moved it closer to my base.