[Bug/exploit] Attempted to remove building and mined dirt returned

I mined out an area of dirt that I did not intend to. And thus tried to build a wall of stone to fill in the gap. It, however, did not finish. So, I removed it, and suddenly the dirt that was mined away was back in place of the wall I had tried to build. No other part of the mined away area returned.

Steps to reproduce:

  1. Mine away an area in dirt, and let it complete.
  2. Attempt to build wall that does not finish.
    3)Remove building(unfinished wall)
    4)Dirt has re-appeared in the place of the blocks that should have been built by wall/building.

Expected Results:
Building/wall should have completed or been removed

Actual Results:
The dirt came back that had been mined away previously, but just where I had attempted to build.



Version Number and Mods in use:
a18d3131, Smart Crafter mod, Crusader mod

System Information:
Windows 8.1, i7-3770k 3.9Ghz Quad Core, 16GB RAM, Nvidia Geforce GTX 660ti 2GB

4 posts were merged into an existing topic: Removing slab results in sculpted terrain