Bug bad frame transition to "unit_not_ready" from "started"

a21r703

#1

Summary:

error when trying to use tool on not placed item. (item no more in inventory [i sell it before placed my mistake :p])

sorry i forgot to copy past the complete error log.

(how i can delete a item no already placed ? )


#2

I think it’s not possible to delete a ghost if you sold the item. But if you craft or but more fences, they will get placed where the ghost is, and you will be able to undeploy or remove them.

If it’s bothering you, you can select the ghost, and type destroy in the console.

The error you posted is not from trying to delete the ghost item. It comes from someone trying to rescue an incapacitated hearthling. Do you know who was rescuing who, when the error appeared?


#3

sorry no i dont know. I dont have a guy need to rescue.
i dont have the save game from this error.
so now i have a crash --> game quitint without a error. i have to up the file named : crash.dmp ?

for the screen it is hard to have this item… it is a fine item… for recreate this… hard :stuck_out_tongue:


#4

Maybe it was someone trying to heal, I’m not sure :thinking:

I see :sweat: you can select the ghost fences and type ctrl+c to open the console, then type destroy and hit Enter, and they should disappear.

Yes, please. :slight_smile:


#5

here the same error again.
release-703 (x64)[M]
(12418 Cecily Raile) (stonehearth:combat:heal) bad frame transition to “unit_not_ready” from "started"
stack traceback:
[C]: in function 'fn’
stonehearth/services/server/threads/thread.lua:346: in function 'private_msg’
stonehearth/services/server/threads/thread.lua:543: in function '_dispatch_messages’
stonehearth/services/server/threads/thread.lua:403: in function <stonehearth/services/server/threads/thread.lua:384>
[C]: in function 'suspend’
stonehearth/ai/actions/run_effect_action.lua:79: in function <stonehearth/ai/actions/run_effect_action.lua:38>
[C]: ?
[C]: ?
[C]: in function 'execute’
stonehearth/ai/actions/run_putdown_effect_action.lua:36: in function <stonehearth/ai/actions/run_putdown_effect_action.lua:24>
[C]: ?

[C]: in function 'run’
stonehearth/components/ai/ai_component.lua:595: in function <stonehearth/components/ai/ai_component.lua:579>
[C]: in function 'xpcall’
radiant/modules/common.lua:265: in function 'xpcall’
stonehearth/components/ai/ai_component.lua:579: in function '_thread_main’
stonehearth/services/server/threads/thread.lua:273: in function <stonehearth/services/server/threads/thread.lua:270>
[C]: in function 'xpcall’
radiant/modules/common.lua:265: in function 'xpcall’
stonehearth/services/server/threads/thread.lua:270: in function 'f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>

and for the other the crash dump
crash.zip (44.0 KB)


#6

I have the same bug as above

HERE