Backpack capacity exceeds supported capacity

The bug is solved thanks

develop-3362 (x64)[M]
@stonehearth/components/storage/storage_component.lua:178: New backpack capacity (10) exceeds supported capacity (8)
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:484: in function 'verify’
stonehearth/components/storage/storage_component.lua:178: in function 'change_max_capacity’
stonehearth/jobs/trapper/trapper.lua:78: in function 'fn’
stonehearth/components/job/job_component.lua:141: in function '_call_job’
stonehearth/components/job/job_component.lua:374: in function '_remove_all_perks’
stonehearth/components/job/job_component.lua:384: in function 'demote’
stonehearth/components/job/job_component.lua:244: in function ‘promote_to’
…s/server/town/orchestrators/promote_orchestrator.lua:71: in function ‘_change_job’
…s/server/town/orchestrators/promote_orchestrator.lua:22: in function '_trigger_cb’
radiant/modules/effects/trigger_effect.lua:14: in function 'fn’
radiant/controllers/nonpersistent_timer.lua:56: in function 'fire’
radiant/controllers/time_tracker_controller.lua:82: in function <radiant/controllers/time_tracker_controller.lua:82>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/controllers/time_tracker_controller.lua:82: in function 'set_now’
radiant/modules/gamestate.lua:9: in function 'set_now’
radiant/server.lua:60: in function <radiant/server.lua:58>

The error is saying that a hearthling was carrying more then he or she should be able to. Are you using any mods, Can you provide a copy of the save file for the devs to check out, a little more info about the event would be useful.

Yeah he’s using mods, you know because of the first line [quote=“FbJs, post:1, topic:29382”]
develop-3362 (x64)[M]
Can you post which mods you are using?

1 Like

I’m using a mod it is “Minecart and Rails”:

Uhm, that mod does not change the hearthlings backpack sizes. I would thought that you were using a mod that has new classes or changes to the current classes in some way. As that is not your case, it must be a bug within the game?

Is this a save that you have since the last versions?
(maybe you had someone with the old high limits and it leveled up in the new system where the limits are lower? Probably the trapper?)

the world (or save) is of the alpha 21
this isn’t a big bug, it doesn’t create problems(currently)

I had the same error popping up. It happened when I changed the profession of my trapper to shepherd. I thought he was carrying his full extended capacity as trapper and that was the reason of the error. I saved after the profession change, reloaded, and the error didn’t appear anymore. Maybe that was the reason.

Have fun, Kyth.

Yes, I changed the job of my trapper to shepherd and the bug is appeared. ok Problem solved thanks bro

1 Like

Fixed for the next build. Thanks all!