Assertion Failed!


#1

Pretty sure that the lua code isn’t just supposed to break like that… ideas on how to fix it? Not really too sure, but I figured I should give some feedback to somebody.


#2

hey there @Gubgub45… thanks for the report, but can you provide some context? what were you doing when this error prompt popped?


#3

Well it just sort of popped out of the blue, I think the major process that was happening was when the they were all standing around the fire after collecting a lot of wood. Then i tried to move the tracker a couple of times and have the workers build a house. I am pretty sure it happened when i tried to move the tracker and build the house at the same time, something got confused in there, but that doesn’t make sense in the coding since wouldn’t these be two separate objects and handle themselves separately. Let me try and get the problem again, and tell you more specifically what happened.

on the mission


#4

Ok so this time it was a little different… I was just making beds, then when they placed them they got caught in an infinite sleep cycle. I looked at them for a little bit as the tracker was really far away, and started to scroll towards him, as soon as i scrolled off of the other civilians, the lua script error popped up. Btw, the carpenter was still making beds. Does it have something to do with the tracker’s movements? or possibly the workers cycle?

edit:
@SteveAdamo this was supposed to be a reply to you sorry


#5

@SteveAdamo do you need a screenshot?