Animating a crab

I had this crab for a while.

As the desert is getting more and more customized, I finally started working on the archipelago creatures.
I sliced it with the correct matrix names and added the same animation rig used in other critters (the rabbit rig). It was horrible as expected, and too jumpy :unamused:
I tried using the goblin rig (image below) and it moves the members too far away, and also jumps a little with each step.
I wonder if there is a rig in the game right now that would be better for this little guy. I “could” do one myself, but I took a look at the animation files and no way I will be able to work with it, had no idea even from where to start… :sweat_smile:


hmm… well i’m pretty sure that when people are looking to start animating they’re often pointed to Voxelpirates blender add-on and tutorials,

other then that i’m not sure… perhaps @Hyrule_Symbol symbol can give more info?


Ha, the irony of a crab commenting on a post about crabs :smile:

I will take a look at it. (I had only a few minutos of experience doing animations before)


I’d say the Poyo has the best chance at looking at-least a little decent? But i doubt it’ll took natural enough

Hahah well, nobody whould dare to manualy make all those numbers move, they’re just… not good for the mind
You usually just use the blender add-on that Voxel-Pirate provided to do all the math for you, the files themselvs are just number representing every object’s location and rotation on every single frame

I could help you make your own animations if you want to, just PM me and i’ll be able to help you out when i can


Have you thought about using the varanus? It may work…

Have fun, Kyth.

1 Like

How could I forget about poyo and varanus…

Anyway, I tried those after I saw your replies, but still not good. The pivot points are too far from the matrix making the movements very large, I could scale my models to better fit the animation points, but I do not think it would be much better…

I just downloaded blender, I will experiment with it a little.

I also tried this little guy with poyo animation, it worked on land, but not in air (pivots too far away)


So, the crab is back. :crab:

I tried to animate it and failed. Not that it was a bad animation, but that it was no animation at all. No movements…

I stripped everything and made a mod with only the crab, here: (65.4 KB)
Use debug to spawn it. (crab_mod:critters:crab)

I tried adding a very simple animation, (because I messed up and lost my previous “good” animation) it will just open his hand, (in a very bad way) but I didn’t care, was just to check if it was going to work in game, and it didn’t… :forlorn:

@Hyrule_Symbol (and anyone else that knows how to animate) if you guys can help… Can you tell me why it is not working, what I messed up?

1 Like

the animation you have there has no root, it’s a bone that doesn’t really exist but is added to the skeleton and animation, if you’d like to i could add you to discord or skype and screen share to teach you how it works, i can’t see any difference aside that, at-least not any that i can notice
my best guess would be that it doesn’t have a root, but i’m not too sure to be honest

PM me if you want a call or something, or els i could try to help you here, assuming you did it in blender

I did it in blender. Using that add-on suggested above.

How do I add the root? (Using the add-on for blender)
I checked the in-game animation and now they have that “attovercog” piece… Is that the same thing as a root? Does it have to have that exact name?

I should also mentioned that the file generated have all pieces prefixed with the entity name, like crab.body. I removed them all, because the game animations does not have the prefixes.

well, i found one clear issue

i assume you don’t use QC and it seems like the program you used actually optimized the size and position of the matrixes

as seen in the golem, all matrixes should be the same size (the thin outlining box), and the position i think doesn’t matter, but the size definitely does

the root is added by editing the skeleton or making a temporary object inside blender (not in the model but in blender when animating) and must be animated alongside the entire model, i think there are some ways to go around and somehow fix existing animations, but i’ll need some testing on that side

but because of the model’s boxes being off, i think it’s pretty safe to say the chances of recovering the old ones are a little slim than usual

I don’t wanna spam the page, but i believe @MelOzone had a similar issue with this, but i’m not sure if he/she just compensated or manage to fix it


Work attractive, congratulation!

I manually added a root and that attovercog to every frame, and it didn’t have any effect. And to the skeleton file too.

I’m using VoxelShop.
There is an option “use bounding box as matrix” which was unchecked. And another “use origin as zero” which was checked. I tried multiple combinations of options and none worked…

I’m going to watch a few more tutorials… Unfortunately that one about the add-on was super long and slow, couldn’t watch past the second video… I’m revisiting it now, probably there is some good info buried there and I’m going to need to watch it all.

I’m pretty sure if you changed the settings it would break the animation, since the relations between each object would be changed, if you could send me the whole thing again (including obj’s and such) i could try to Track down some issues

I think the .qb file is ok, cause it is animated when I use the goblin animations… (141.7 KB)
I added at the root of the mod the .dae file that I exported from VoxelShop to Blender and a .blend with the project. (The animation is all messed up, I don’t mind it, it was just to see if it moves.)

I found that there was that stonehearth tab at the bottom of the scene menu, there it asks first for a skeleton file, which I don’t have cause it is a fresh model and animation, but what I did was export an skeleton file and then import that same file… The “prepare skeleton” and prepare animation finally toggled the green light at least.

But in game it is the same thing, the mob is just standing there, without animation…

okay i finally got to testing in the game (spawning it in)

and i realized that the animation just isn’t loading?, i mean, all the paths are correct since there was no error message, but seeing that it moves but doesn’t animate (and rotates along a wrong axis) my best bet is that the animation isn’t correct, a main cause can be names of matrices, or wrong names in the skeleton or animation since the game ignores objects that don’t match the skeleton or animation and is in the model as just part of the root

i found that the location and boxes of the model itself has been fixed by you editing the settings in you exporter, but the skeletons all have a name of crab.righthandpincer and not only is that incorrect, the game in animations is actually case sensitive, so if your model has a name of [rightHandPincer] the skeleton and animation must have the same name in lower and higher cases, the best way is to edit the model, but since there’s a crab. only in the skeletons, i think that can be fixed by editing the model to have all parts have lower cased letters and editing the skeleton to not have the crab. in front since all the animations seem to not have the weird name

i’d prefer a call since i’m not that good at explaining things via text, but let me know how it went after you changed those

Oh, those errors were left there on purpose, to show how the files are being generated by the plugin.

I had fixed it manually before, mentioned a little above, here:

But, I didn’t noticed it was also all lower cases… This time I’m going to remove the prefix AND fix the letter cases. I hope it was it… Testing now.


Ok, I’m really mad now. It was really the letter case fault!!! And I didn’t even like to use camelCase, I only used because I copied from other in-game models…
But what really got me angry now is, why the hell the plugin/blender changed it??? That was super stupid, sorry, I’m angry :rage: :rage: :rage: (And I’m even forgiving the prefix, which are also stupid, why it is adding those things??)

Now, a second problem, the “scale” of the animation… At first I thought it was again not working, but upon a super zoomed in camera movement, I noticed a “half pixel” movement… Yep, it is moving, just the scale is so small that is barely visible, almost thought it was just anti-alias working there. Never mind the scale, it was just the bugged animation from before, a new one showed me it is correct now.

Although, the axis is wrong, I’m going to need to rotate the model before animating it.

1 Like

That’s odd, i use the same add-on and it never makes pre-fixes or case changes, i have no idea what’s happening there
My add-on was modified by @honestabelink back in the day, but it wasn’t for cases and pre-fixes

For the anination testing, i’d suggest setting up a new skeleton and animation set to fully test it out since your model’s position and relation has changed, and perhaps make a test animation that you can remember precisely and see if the game reads it wrongly and try tracking that reason afterwards

In case you didn’t know

Before pressing the “prepare animation” button, make sure all parts are under the root parent, so if the hands are children of the body, the body is the child of the root and feet are child of the root so if you move the root all parts follow, and makes sure it’s all set up and save for future uses and after that press the prepare animation button

If animations are too small or looks weird, make an animation with asymmetric rotation and movement, say, in blender, the right arm goes up and rotates inwards, and the legts side loves leftwards and rotates outwards and forwards, so you can check if any of the skeletons or settings were wrong,
Or if the movelemt is too small, make certain parts of the animation move in drastically different distances to see hot it effects the in-game animation

I’ll sleep now, i’ll get to seeing how it went as soon as i’m up again

After seeing the edit the main preblem is the changed model, so you’ll have to make a new skeleton and animation

This was diagnosed by looking at the hand being rotated from the wring axis