Water error once game loaded



Every time I load my game, there is an error who pops up directly. I tried to build a canal around my kingdom but the water broke.

Here is the error:

release-737 (x64)
stonehearth/components/water/water_component.lua:794: assertion failed!
stack traceback:
radiant/modules/common.lua:245: in function 'report_traceback’
radiant/modules/common.lua:256: in function <radiant/modules/common.lua:250>
[C]: in function 'assert’
stonehearth/components/water/water_component.lua:794: in function '_remove_height’
stonehearth/components/water/water_component.lua:261: in function '_remove_water’
stonehearth/components/water/water_component.lua:473: in function ‘fill_channel_from_water_region’
…hearth/services/server/hydrology/channel_manager.lua:561: in function ‘callback_fn’
…hearth/services/server/hydrology/channel_manager.lua:194: in function ‘each_channel_ascending’
…hearth/services/server/hydrology/channel_manager.lua:559: in function ‘fill_channels_to_capacity’
…arth/services/server/hydrology/hydrology_service.lua:768: in function ‘_on_tick’
…arth/services/server/hydrology/hydrology_service.lua:52: in function ‘fn’

radiant/controllers/time_tracker_controller.lua:84: in function ‘set_now’
…hearth/services/server/calendar/calendar_service.lua:421: in function ‘_on_event_loop’
…hearth/services/server/calendar/calendar_service.lua:46: in function 'instance’
radiant/modules/events.lua:291: in function <radiant/modules/events.lua:285>
[C]: in function 'xpcall’
radiant/modules/common.lua:265: in function 'xpcall’
radiant/modules/events.lua:285: in function 'trigger’
radiant/modules/events.lua:398: in function '_trigger_gameloop’
radiant/modules/events.lua:446: in function '_update’
radiant/server.lua:61: in function <radiant/server.lua:58>


Version Number and Mods in use:

build: stoneheart 0.22.0 (release 737) x 64
mods: none

System Information:

os: Windows 10 Home
CPU: Intel® Core™ i7-3770 CPU @ 3.40GHz
RAM: 8.00GB
GPU: Geforce GTX 1060 3GB OC edition


Water’s been broken for who knows how many releases now, and will be until @Albert finishes fixing it. Hold fast brother…one day you’ll have your moat.


My workaround for this is to dig all of the moat except for a 1 block thick wall holding back the water. Then take the wall apart one level at a time from top to bottom. The problem with the error seems to be when you take out a 4 block chunk and the hearthlings do it unevenly.