Smoke particle effect remains after demolishing a building

A post was split to a new topic: Demolish effect remains after reloading the game

Summary: Dust doesn’t disappear when building is bulldozed

Steps to reproduce:

  1. Build a structure
  2. Pause the time then remove the building twice
  3. Play the time again

**Expected Results:**Dust will eventually disappear

Actual Results: Dust got bugged and continuously does the animation of dust



Version Number and Mods in use: 0.19.0 release 687 better stockpiles mod and smart crafter mod

System Information:

This has been reported before, but the last report I could find was marked as resolved.

Clearly this exact case isn’t resolved. I followed your steps in Alpha 20 and also got endless dust.

Does it go away if you save the game and then load? I know that’s fixed this sort of issue before.

Just for completeness I have encountered this graphical bug today in the most recent release-695 (x64). A re-load of the file remedied the situation. I was trying to experiment with a cellar for future buildings. So I was building directly in a dug out hole.

1 Like

Yes a simple reload will fix the issue. :slight_smile:

1 Like

I destroyed a building and now the thing wont go away

I’m good at finding bugs :merry:

Upon reloading the save it was fixed

This is a pretty old bug, and it’s described differently every time, so finding a still running report for it took a bit of work searching.

Here’s the one I found, in case a moderator wants to merge this.

1 Like

Summary: So I was first making a small bridge to start off with. When I made a proper bridge I simply removed the first one. And I did… But not there’s dust floating above the water for eternity

Steps to reproduce:

  1. Build a small bridge
  2. Build another bridge(bigger and prettier) next to the first bridge
  3. Pause the game
  4. Click on the remove button TWICE(I thought the game didn’t respond, but then realized the game was just paused) :sweat_smile:

Expected Results: That it would remove the constructed bridge

Actual Results: There’s dust floating above the water for eternity. I waited 3 minutes with 2x game speed. Still dust.

Notes: The effect is actually kind of cool. In some way it looks like a muterious bride made from witchcraft… or something


Please take note for the real life time and the game speed

Had an engine error but don’t think it has anything to do with this.
release-701 (x64)
c++ exception: lua runtime error
stack traceback:
Version Number and Mods in use: A-20 release 701 / x64-bit

System Information: Inappropiate in this case

This sort of bug has been around for a while. Does the cloud disappear after saving and loading the game? Then it’s exactly this bug.

But with that bridge being built over water, it looks a lot like one specific variation. If the smoke doesn’t disappear when reloading, then it’s almost certainly this particular case.

(Both of those may very well be the same bug, but that’s for the actual @moderators to decide.)

1 Like

It’s gone now. Guess I should have had patience to reload the game.
Thx for reading

Tried to remove house, house was not removed, but instead just turned into a smoking pile of dirt.
Steps to reproduce:

  1. Build a selfdesigned house and forgot to put a roof one the building after all the walls and such was done building
  2. Tried to add the roof afterwards, but hearthlings didnt reach
  3. Tried to remove the house by clicking remove, and agreeing to remove on the warning.
  4. House was not removed but just started smoking what I belive to be decontruction smoke.
  5. Nothing I can posibly do and it ruined my city 19 in game days into the game

Expected Results:
Removing the house for me to builf a new on in its place
Actual Results:
Building was not removed, and started smoking decontruction smoke
Harsh work invironment due to smoke (Angry hearthlings)

Version Number and Mods in use:
Realease-763 (x64)
System Information:
Win 10

1 Like

No mods were in use at this time

Does saving and reloading clear it? If not, post the savegame - that would help fix the issue.

1 Like

There are two versions of this bug. One that fixes on save-reload, related to the UI, and one related to the building system itself, that doesn’t fix on reload.

Instructions for uploading the savefile if it’s the second case:

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

Did you click on Remove after it was finished building, or while it was being built?
Did the house connect with another already built structure, like another house or a road?

Let’s hope they dont form a union.


I’ve actually had this bug before as well! However, I was able to destroy the actual building – the smoke still remained. I built “The Steampunk Inn” on top of it :stuck_out_tongue:

Glad to see that there’s a fix for this! Too bad I “retired” my old town…


Sorry, I was too stupid to save even though I know it is Alpha build, so there is no save file. And near future after I posted this thread I started a new town cause I did not loose to much by doing it. Only 19 in game days, so sorry about that. @Relyss


When I created a big building, I realized I messed up so I removed the in-progress building while they were still digging the floor. When I did this, the destruction animation occurred and the dust clouds began. But instead of them going away, they just kept playing and didn’t stop.

Steps to reproduce:

  1. Create a building, mine was 19x11 base with a 9x9 base add-on
  2. Let the Hearthlings begin to dig the floor
  3. Remove the in-progress building half-way through dig

Expected Results:

Dust clouds appear for a short amount of time and then disappear

Actual Results:

Dust Clouds did not disappear


I waited for the clouds to disappear for 2 minutes on super speed.
Reloading the save did get rid of them but it would be nice if they would go away without having to.


1 is result and 2 is the house I built that caused this

Version Number and Mods in use:

release-763 (x64), no mods used

System Information:

64-bit operating system
Window 10 version 10.0.16299
Processor: AMD FX-8300
Graphic card: GeForce GTX 960

I placed a standing wall as if for a defense wall around my town. Wanting it to look more of a castle
I placed Slabs on top of the Free Standing Wall. After removing the Free Standing Wall the Slabs were hovering. I then removed the Slabs in Pause Mode. After all Slabs were removed the cloud appeared. See pictures for what the bug looks like
Steps to reproduce:

  1. Placed a Free Standing Wall
  2. Placed some Slabs on top
  3. Removed Free Standing Wall (Slabs are hovering)
  4. Removed Slabs
  5. Cloud Forms (Bug)

Expected Results:
Cloud Forms
Actual Results:
Cloud Forms


  1. Steam Community :: Screenshot
  2. Steam Community :: Screenshot
    Version Number and Mods in use:
    Version Number: Build 766
    System Information:
    OS: Windows 10 64x
    GPU: GTX 1060
    RAM: 16GB
    CPU: AMD FX 8350
    Stonehearth is installed under my C Drive (250GB SSD)

Update: Bug is no longer there after saving, quitting to main menu (not desktop), and clicking the “Continue” button