Slow, Unplayable Lag


I have hit a point in the game where it is so slow it is essentially unplayable. I have about 20 hearthlings, which from the other posts I’ve read seems to be around the limit the game can currently handle, but I thought I would chime in anyway.

The performance bar hops between 99% LUA and 99% LUA GC

In the other posts I read, people tried turning down graphics settings, but I have a 980ti. I think it should handle any thing I can throw at it. Any suggestions?

Operating System: Windows 10 Pro 64-bit (10.0, Build 14393) (14393.rs1_release_inmarket.161208-2252)
Processor: Intel® Core™ i7-2600K CPU @ 3.40GHz (8 CPUs), ~3.4GHz
Memory: 12288MB RAM
Card name: NVIDIA GeForce GTX 980 Ti

I’ve had similar problems too, but I haven’t tried lowering graphics quality yet.

I don’t know, but I think it could be the CPU.
Mind checking the performence tab of your task manager while playing the game?
It should show you how much of your CPU is being used.

So, the above screenshot is right after loading the game up. I’m not seeing the slowdown now. It seems like restarting fixes the issue, at least temporarily.

Have you built walls all the way around your town, and if yes, are there lots of goblin/orc/varanus/etc camps outside of town sitting around doing nothing?

I have not built walls around my town. I have, however, built nearly my entire town into a mountain. I hadn’t built a single building until this morning, and I was seeing the slowdown before that.

Regarding enemies outside of town, I had the large army show up, the one with Mountain, on a plateau where they couldn’t get to me and they just stood around. I want seeing any a* usage though, which is what I would expect if they were constantly trying to path.

I’ll upload my save later today, if that helps.

I have the same issue with everything being open in plains. The slowdown happens after a significant amount of playtime, restart fixes it 2 seconds into the loaded game every time. It has nothing to do with what or where you build, they simply stop ( nearly )

edit : a word

To the developers: I can get super technical if need be. Let me know if you want any specific debugging done or anything I can do to help. I think you’ve made a great game so far and I’m willing to help out.

edit: words

I was concerned about A* yeah, so if you’re still having the issue with your save, please post it and any repro steps you’ve noticed : ).

Just here to mention that I’ve got the same problem with basically the same specs, in a plains area but with walls surrounding my town.

Just here to mention that I’ve got the same problem with basically the same specs, in a plains area but with walls surrounding my town.

Now after playing a bit more with the fram-y movement of my townies, I’ve got some info for you. So during a night I got invaded by some large ogre and archers (kobolds?). During the first encounter (reloaded an older save file after messing something up) they attacked my town walls and started chipping away at my gate, brought the fight to them and it was still having the whole slow down issue. After that I reloaded the save file, went out of my town and brought the fight to them. The slow down problem solved itself once I had left the town with my fighting unit. Reloading the save file usually only helps for a minute or so, and that remained the same over the course of both the scenarios. .

edit: additional info

I’m testing my situation now on a completely fresh save. As soon as I manage to recreate @Cranor his suggestion with a fighting unit, I will post my steps here.

1 Like

Okay so I got to the point where the lag kicks in without even having any footmen. Also I get about 70% idle in CPU. It seems theres too much stuff laying around that stacks up, many items arent picked up but theres plenty of space. Everything is accessible and the paths are clear. I also only had 7 people yet, I just let it run without adding people and after .about an hour it started to lag incredibly, I have reloaded the save and am counting now for the second laggspike to hit. Will report further in this thread.

1 Like

Cannot get the replication again, am now running with 0 characters to make sure it’s related to the Hearthlings.

As I finish typing this first sentence my game starts lagging with 0 hearthlings on the map.

This is the use of CPU currently.

The lag happens under almost any circumstance I’ve tested thus far, after about half an hour to an hour ingame.
My PC is not the issue as it runs many single threaded sims perfectly as well as ArmA3 and other high end simulators.
Any other logs needed ? I’ll keep the game open for a few minutes to see responses

@Cranor @lobstertech

Can you try to run a game and let all your hearthlings die slowly and see if you still end up lagging without hearthlings, jobs queued, no mines and no harvest jobs open.

as it keeps running the LUA_GC tab turns between 0 and 20 for no apparent reason it doesn’t if there’s no lag. Perhaps it appears and disappears quicker without lagg and it doesn’t catch my eye.

1 Like

So summary

  • with 0 hearthlings I still manage to lag epicly, with my CPU fully calmed down and idling.
  • lua_gc will sometimes take up to 20% of the cpu during this lag
  • combatparties do not speed up the process towards the lagging
  • reproductionfactor used is TIME on my specific machine, nothing else has been done in the same way to ensure it’s not a set scenario where this triggers (environment,hearthlings,classes) all have been excluded

As stated above there is no specific answer I can give as there was litteraly nothing going on for 30 minutes before it started lagging.


@malley: So I think I figured out what is up. When the slowdown was happening, there was a small army stuck on a plateau with no where to go. This included goblins, a few big orcs, and like 3 varanus(es?). The issue was not A* though. It was Lua and its garbage collector. The UI was still fairly responsive, but, anything happening in the 3d world was like 10fps (even though i was getting 50-60 fps).

I hope this helps.

1 Like

Interesting, I’ve only seen that happen with A*. @not_owen_wilson Do you know what could have been happening? Do you need a save to take a closer look?