[Res] AI Error (Aggro Observer)

Hello, i always get the same error messages about twice in one in-game day. Often before enemies spawn. Goblins stopped spawning after the first message. Undead are still working.

3 Likes

Can confirm, got the exact same error (R375). In my case it was after combat had already taken place some; the first was when there wasn’t even any combat immediately active. (I thought it had to do with the shepherd before I looked at the error itself.) See video. First at 56:00, then 57:55, and then just continually until the end of the video, when I stopped playing.

1 Like

Can confirm same error happening during the peaceful game mode. It started with only a couple messages but more appeared over time. I’d like to note, only the red error box appeared for me, rather than both that the OP was given and it only started happening after my shepherd hearthling got his second sheep. (I’m about 7 or so hours into gameplay)

Error Progression: The first appearance of the error | After the remainder of the night and most of the next day had gone past

UPDATE: Since posting this reply an hour ago, the number of instances of this error appearing has drastically increased. I now have giant red wall with over 130 reports of this error. Upon closing the window, it only takes a couple minutes at most for it to reopen with more error occurrences. As such it’s making game play increasingly difficult to focus on, rather than th…142 instances…143…

Closing and restarting the game has no (165) effect on (175) the frequency off this error occurring (177) sighs I’m going t(179)o attempt to start a new game(190) and (199) see if (215) the issue persis(217)ts on a different ‘map’. (219)

As you may have noticed from i’ve been adding the updating number of error instances into the post to keep track and illustrate the problem I’m experiencing. I’m not a slow typer by any means and frequently type without looking at my keyboard so each number I’ve noted up until the end of the previous paragraph have all been noted in realtime. You can clearly see that while some of the instance report repetitions are small. Others are most definitely not and happen very close together (as noted by the number of reports jumping from 199 to 215 in the space of 1 second realtime)
At the point of my writing this particular sentence before I attach the screenshot I took of the wall, the number of recurring instances was up to 224, all identical: aggro_observer.luac:49 and aggro_observer.luac:52.

Screenshot: Final screenshot taken off the error report wall prior to posting this updated post.

1 Like

All of that is the same for me.

[Edit: Next four posts merged from “Attempt to index local ‘traces’ (a nil value)”]

5 Likes

I keep getting error messages when the shepherd makes the tune. This is what it says stonehearth/ai/observers/aggro_observers.luac:52: attempt to index local ‘traces’ (a nil value). My game is in peaceful by the way not sure if that makes a difference or not hope this helps.

I’ve been having that same error message pop up. I didn’t realize it was his tune lol. I just thought it was the special noise for error messages. This happened a lot before my save stopped working altogether because the lua was taking up too much memory.

firstly, welcome to the stonehearth discourse, @CenturionGaming :smile:

secondly, did you perhaps get a screenshot of this error? though you are a new user and wont be able to upload it directly onto the dicourse, if you put it on imgur.com or som such place then @SteveAdamo @Relyss could embed it for you :blush:

3 Likes

Here is the link to the screenshot

its just the error message and my little town in the background

2 Likes

[Edit: Next three posts merged from “Bug: getting error messages when shepherd makes tune”]

3 Likes

I can’t quite tell what the cause fo this bug is. It has caused the village people to just stand around and not find pathing to a number of resources. I can’t figure out how to attach a screenshot but the error is stonehearth/ai/observers/aggro_observer.luac:49: attempt to index local ‘traces’ (a nil value). I think it started when I tried to remove a fence.

hello @Ryion welcome to the discourse :smile:

[quote=“Ryion, post:1, topic:12793”]
I can’t figure out how to attach a screenshot
[/quote]seeing as your a new member you wont be able to directly upload one to the discourse, however if you upload one to imgur.com or some such place im sure that @SteveAdamo or @Relyss would be more then happy to embed it for you

1 Like

Thanks guys! The aggro_observer was already fixed and will be in the next patch.

7 Likes

I have an error message with the "aggro system. Here still a screenshot.

www.pixenli.com/images/1433/1433498461022460200.png
http://www.pixenli.com/images/1433/1433498461022460200.png

Welcome to the forum, @Rapishiny :smile:!

Thanks for reporting :thumbsup:

I’m piling up a bunch of reports of this error from other users to merge them, although apparently it’s already fixed for the next build.

1 Like


I keep on getting these error popping up in game. currently playing on a peaceful map.

Absolutely entertaining and engaging game!

I’m experiencing the same issue (also on a peaceful map).

I receive errors (no exaggeration) every 8 to15 seconds. The errors are very regular and began within the first 20 minutes of gameplay.

Window 7 64bit.
AMD HD7770 updated to the most recent (beta) drivers to in hope of alleviating the situation. Efforts were unsuccessful.

12e3e1a0-0b77-11e5-acc4-446d57567ea7

This is pretty much constant now, as soon as I close the error it reappears.

I have resorted to leaving the error open and just moving the error box off screen as much as I can.

Hope this gets looked into soon.

I believe this is the same bug as the one here. Albert from Radiant has said that the bug is fixed for the next patch. That doesn’t help with your current world though, so all you can do is either put up with it or start a new world. The fun of alpha right?

3 Likes