Clan Amberstone mod


#1

Hello, I am just going to start posting my progress and work of a kingdom mod for the bunny people in here…

Version:
https://steamcommunity.com/sharedfiles/filedetails/?id=1435316938

I started off as a shameless Nord reskin, changing the naming structure and tables to make a cloned mod, before Going to change everything bit by bit…

at the moment I got mostly every basic change done. the usable Quests personally are causing me alot of grief with an indexing nil error I cant for the life of me hunt down…


#2

if anyone knows where the Nil error would be probably originating, this is the Log I been using to find it.

release-875 (x64)[M]
…th/services/server/population/population_faction.lua:535: attempt to index field ‘?’ (a nil value)
stack traceback:
[C]: ?
…th/services/server/population/population_faction.lua:535: in function ‘_generate_citizen_from_role’
…th/services/server/population/population_faction.lua:515: in function <…th/services/server/population/population_faction.lua:511>
(tail call): ?
…er/controllers/encounters/town_upgrade_encounter.lua:213: in function ‘stage_2_congregate’
…er/controllers/encounters/town_upgrade_encounter.lua:200: in function ‘stage_1_setup’
…er/controllers/encounters/town_upgrade_encounter.lua:112: in function ‘stage_0_wait_for_facility_in_world’
…er/controllers/encounters/town_upgrade_encounter.lua:103: in function ‘start’
…ervices/server/game_master/controllers/encounter.lua:128: in function ‘start’
…arth/services/server/game_master/controllers/arc.lua:407: in function ‘_start_encounter’
…arth/services/server/game_master/controllers/arc.lua:383: in function ‘_trigger_edge’
…arth/services/server/game_master/controllers/arc.lua:315: in function ‘_trigger_out_edge’
…arth/services/server/game_master/controllers/arc.lua:289: in function ‘trigger_next_encounter’
…rollers/encounters/town_upgrade_choice_encounter.lua:63: in function <…rollers/encounters/town_upgrade_choice_encounter.lua:50>


#3

I’m assembling here eveybody that I know that can code:
@BrunoSupremo, @Hamnisu, @Wiese2007
Guys, can you pretty please take a look on this? :frowning:


#4

Translated to Human, this says “one of the entries in the celebration NPCs section of your town upgrade encounter is referring to a non-existent NPC”.


#5

I love you!.. That narrows down the error SO MUCH!

I am also literally going off of a history of Javascript I didnt touch in like 2 years… so learning a new language, while remembering the concepts.


#6

well… lets me know that I am looking for an invalid NPC… still gotta deal with finding it.


#7

I initialized my NPC as a female, but accidentally had it marked as Male in the quest… I owe ya for helping me figure it out!


#8

I’m glad to see it got solved!

Thank you for thinking of me, @Bella_Chatlotte :heart:
Sorry for the late reply; today I’m busy with my birthday and within a week and a half I’m getting married, so there’s a lot on my plate atm :slight_smile:

Again, I’m happy see it was solved.
Best of luck with your project @Wesley_Cleary_Foxy_a


#9

Happy Birthday @Hamnisu !!! :tada: Here’s wishing you all the best for the wedding. May your hands be forever clasped in friendship, and your hearts joined forever in love. :merry:


#10

Making headway into the nitty gritty of changing everything…

Anyone know of a command to force a trait to be used. I feel like forcing the herbivore trait would be nice…


#11

Can someone direct me to the non-steam workshop way of obtaining this mod?


#12

Sorry, I didnt create one yet… I will do so probably next Update patch around tomarrow ish?..