Cancel Mining Not functioning as expected/bugged


#1

Summary:

Steps to reproduce:

  1. mine an area
  2. Click cancel jobs
    3)Mining areas disappear and cannot intuitively (at least) be canceled

Expected Results:
Mining areas should be visible and operate like trees and be able to be Canceled through the same interface.

Actual Results:
Mining areas disappear and cannot be selected

Notes:
none

Attachments:
none

Version Number and Mods in use:
dev 2922 x64 no mods

System Information:
amd athlon 64 8 core, nvidia 970GTX, windows 7
not grate but let’s me run this so I’m happy.


#2

hey there @ransombot,

hmm… maybe i misunderstood you, but i’m not certain this is actually a bug.

similar to the way blueprints work with the building tab, mining zones are not visible unless you have the mining tool selected, so is you hit M and all mining zones should be visible, then just clicking on one should bring up the option to cancel it.

if that isn’t happening though, then this is definitely a bug.


#3

I am also pretty sure that it’s not a bug


#4

Tried to explain in the title not as expected or a bug, I as a semi casual user of it expect the cancel jobs button to cancel mining jobs as well as trees. While it may not be a “Bug” there should be some way to cancel mining in the same way you would trees as the button for all of them are on the same menu.

My reasoning for this is:
All the buttons for those functions reside in the same menu, and a “normal” user would expect them to function with each other, not functioning that way makes it a strange experience. It also lessens the amount of clicks to have it that way. If mining functions differently then it should reside elsewhere and have a way to quickly edit mistakes for those that don’t think or want to pause for edits, or fixes to edits that go out of control.

Is there a way to change this to a feature request? Sorry for posting this in the wrong area.