Bugs that i've found


#1

develop-2924 (x32)
…ter/controllers/encounters/create_camp_encounter.lua:411: attempt to index local ‘ctx’ (a nil value)
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
…ter/controllers/encounters/create_camp_encounter.lua:411: in function ‘_create_combat_listener’
…ter/controllers/encounters/create_camp_encounter.lua:442: in function 'instance’
radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:200: in function 'trigger’
radiant/modules/events.lua:241: in function '_fire_async_triggers’
radiant/modules/events.lua:319: in function '_update’
radiant/server.lua:62: in function <radiant/server.lua:58>

After my footman died a horrible death to two goblin camp spawns and a giant wolf spawn all in the same spot (craaazy right ) They decided to spawn a goblin camp with leader and i got this message.


#2

I kid you not i just saw a hearthling swim… oh my days.


#3

develop-2924 (x32)
radiant/modules/entities.lua:345: assertion failed!
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'assert’
radiant/modules/entities.lua:345: in function ‘distance_between’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:166: in function ‘_apply_aoe_damage’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:137: in function 'fn’
radiant/controllers/nonpersistent_timer.lua:56: in function 'fire’
radiant/controllers/time_tracker_controller.lua:82: in function <radiant/controllers/time_tracker_controller.lua:82>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/controllers/time_tracker_controller.lua:82: in function ‘set_now’
…hearth/services/server/calendar/calendar_service.lua:379: in function ‘_on_event_loop’
…hearth/services/server/calendar/calendar_service.lua:37: in function 'instance’
radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:200: in function 'trigger’
radiant/modules/events.lua:269: in function '_trigger_gameloop’
radiant/modules/events.lua:320: in function '_update’
radiant/server.lua:62: in function <radiant/server.lua:58>


#4

Ignore this dsfhuiaosdflsdf

develop-2924 (x32)
radiant/modules/entities.lua:345: assertion failed!
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'assert’
radiant/modules/entities.lua:345: in function ‘distance_between’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:166: in function ‘_apply_aoe_damage’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:137: in function 'fn’
radiant/controllers/nonpersistent_timer.lua:56: in function 'fire’
radiant/controllers/time_tracker_controller.lua:82: in function <radiant/controllers/time_tracker_controller.lua:82>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/controllers/time_tracker_controller.lua:82: in function ‘set_now’
…hearth/services/server/calendar/calendar_service.lua:379: in function ‘_on_event_loop’
…hearth/services/server/calendar/calendar_service.lua:37: in function 'instance’
radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:200: in function 'trigger’
radiant/modules/events.lua:269: in function '_trigger_gameloop’
radiant/modules/events.lua:320: in function '_update’
radiant/server.lua:62: in function <radiant/server.lua:58>


#5

So what happened here was i attacked a goblin camp with footmen and i got this box… Continued gameplay got some fancy mace kinda thingy from the guy had a solid hour or more of gameplay, Then i crashed and my save files got currupted Aaaaalll the way back to the save where i got This bug report…
Im blaming it.

develop-2924 (x32)
radiant/modules/entities.lua:345: assertion failed!
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'assert’
radiant/modules/entities.lua:345: in function ‘distance_between’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:166: in function ‘_apply_aoe_damage’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:137: in function 'fn’
radiant/controllers/nonpersistent_timer.lua:56: in function 'fire’
radiant/controllers/time_tracker_controller.lua:82: in function <radiant/controllers/time_tracker_controller.lua:82>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/controllers/time_tracker_controller.lua:82: in function ‘set_now’
…hearth/services/server/calendar/calendar_service.lua:379: in function ‘_on_event_loop’
…hearth/services/server/calendar/calendar_service.lua:37: in function 'instance’
radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:200: in function 'trigger’
radiant/modules/events.lua:269: in function '_trigger_gameloop’
radiant/modules/events.lua:320: in function '_update’
radiant/server.lua:62: in function <radiant/server.lua:58>


#6

develop-2924 (x32)
std::exception: 'bad allocation’
stack traceback:
[C]: ?
[C]: ?
[C]: ?
radiant/modules/terrain.lua:203: in function '_is_sane_cube’
radiant/modules/terrain.lua:212: in function 'get_entities_in_cube’
radiant/modules/terrain.lua:244: in function ‘get_entities_at_point’
…rth/services/client/selection/xz_region_selector.lua:279: in function ‘_is_valid_location’
…rth/services/client/selection/xz_region_selector.lua:389: in function ‘_compute_endpoint’
…rth/services/client/selection/xz_region_selector.lua:422: in function ‘_find_valid_region’
…rth/services/client/selection/xz_region_selector.lua:619: in function ‘state_transition_fn’
…rth/services/client/selection/xz_region_selector.lua:529: in function ‘_on_mouse_event’
…rth/services/client/selection/xz_region_selector.lua:826: in function '_mouse_cb’
stonehearth/services/client/input/input_capture.lua:49: in function '_dispatch’
stonehearth/services/client/input/input_service.lua:55: in function '_dispatch_input’
stonehearth/services/client/input/input_service.lua:12: in function <stonehearth/services/client/input/input_service.lua:11>

develop-2924 (x32)
c++ exception: lua runtime error
stack traceback:

develop-2924 (x32)
radiant/modules/entities.lua:345: assertion failed!
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'assert’
radiant/modules/entities.lua:345: in function ‘distance_between’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:166: in function ‘_apply_aoe_damage’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:137: in function 'fn’
radiant/controllers/nonpersistent_timer.lua:56: in function 'fire’
radiant/controllers/time_tracker_controller.lua:82: in function <radiant/controllers/time_tracker_controller.lua:82>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/controllers/time_tracker_controller.lua:82: in function ‘set_now’
…hearth/services/server/calendar/calendar_service.lua:379: in function ‘_on_event_loop’
…hearth/services/server/calendar/calendar_service.lua:37: in function 'instance’
radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:200: in function 'trigger’
radiant/modules/events.lua:269: in function '_trigger_gameloop’
radiant/modules/events.lua:320: in function '_update’
radiant/server.lua:62: in function <radiant/server.lua:58>

Steam 32bit i believe .-.


#7

Hi!
Bad allocation means the game has run out of memory. If you’ve been running the game for a few hours in real life, please save and completely shut down the game and restart it. Although if your town is pretty big, that won’t work after awhile. Is your machine capable of running in 64bit? If so, please try switching to using 64 bit.
Thanks
-Yang


#8

I think i should be… How do i know for sure/ how do i run it.


#9

In user settings, under system, uncheck the “force 32 bit” check box. Apply the setting and then exit the game completely. Relaunch the game and there should be a little (x64) next to the build number in the upper left hand corner.
Let me know if you run into any issues
Thanks
-Yang


#10

Well it appears that i can only run the 32 bit one,
i got an NVIDIA geforce gtx 760
16gb ram and an 8 core processor
im running it from steam


#11

Huh you unchecked the force 32 bit checkbox and it still says (x32)?
Your system specs should be able to run the 64 bit version …


#12

sounds like we found another bug ;O Might be on my end though… hm


#13

What does your user_settings.json look like? Can you copy and paste it?
Thanks
-Yang


#14

{
“user_id” : “af107e9f-057c-11e6-9566-60a44c63c8b7”,
“collect_analytics” : true,
“alpha_welcome” : {
“hide” : true
},
“enable_auto_save” : false,
“renderer” : {
“run_once” : true,
“use_high_quality” : true,
“enable_ssao” : true,
“enable_shadows” : true,
“msaa_samples” : 1,
“shadow_quality” : 4,
“max_lights” : 50,
“enable_vsync” : false,
“enable_fullscreen” : false,
“screen_width” : 1916,
“screen_height” : 1018,
“draw_distance” : 1000,
“last_window_x” : -8,
“last_window_y” : -8,
“last_screen_x” : 8,
“last_screen_y” : 52
},
“audio” : {
“bgm_volume” : 1,
“efx_volume” : 1
},
“force_32_bit” : false,
“language” : “en”,
“mods” : {
“stonehearth” : {
“enable_speed_three” : false,
“default_storage_filter_none” : false,
“randomize_attributes” : false,
“show_hearthling_paths” : false,
“max_citizens” : 20
}
}
}


#15

Hmmmm this looks correct … So if you launch the game from Steam, it will still show up with “(x32)” at the end of the build number at the upper left?

-Yang


#16

yes that is correct ~~~~~~~~~~~~~~~~~~


#17

Hmmm I’m not sure what could be causing this. Is your Operating system 64 bit?
-Yang


#18

Yes i am operating on a 64 bit system it says.


#19

Im going to try to reinstall my videocard driver, maybe its my own fault.


#20

Didn’t work sadly, i hope i can find a fix soon… im not good at this at all :stuck_out_tongue: