Animations are off


#21

I deactivated ACE now and other mod aren´t active so far.
The bug happens nevertheless. This are the only things that are still active:

So I can exclude that another mod is part of the bug, if not “Microworld” or “Autotest” are also problematic.


#22

I report back with new insights.

After digging deeper and deeper in the past threads I found a post where
a problem was described with workers getting stuck when the drop point wasn´t
defined correctly. So they looped forever trying to put the object they crafted into their inventory.

Now I tested if it also get stuck, if I use another work animation than my own. For example the standard animation for crafting: “fiddle”. And yes, the baker get´s stucked at the end as well.

So In conclusion it is neither a problem with mod compatibility, nor a problem of my animation itself (so far I can tell).
The next thing to try is to correct the “drop_offset” I think.
But I´m not really sure from where it is measured from. From the “object_origin” or the “region_origin”?
Comparison with other crafting workbenches wasn´t to revealing. And in the guides here at discourse about “positioning” of objects or the stonehearth modding guide, wasn´t the “drop_offset” described (more accurate).
I experimented a bit, but couldn´t conclude which values would be best so far.
Also I thought about the drop animation of workers when they come to their crafting bench and put the ingridients on top of it. Could it be possible that the crafter hold the ingridients in their inventory instead of dropping them on the bench/floor?


#23

It gets weirder and weirder…
I tracked now in an attempt the AI and concluded that it fails to either drop and then “destroy” the
crafting ingredients or qith picking up the crafting product.
No matter what I changed in the files so far it didn´t help.
But now I tried to replace the oven ingame and it instantly worked. Moving it back to the former position
the bug occured again.

Can anybody explain me why this a bug occurs or may help me please? :slight_smile:
Right now I´m a bit lost, because it invalidated all my other solving approaches :no_mouth: