Alpha 16 - Build 2924 - Error Assertion Failed


#1

Summary:

  • I was putting some light
    OR
  • A knight level up during combat

develop-2924 (x64)
radiant/modules/entities.lua:345: assertion failed!
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'assert’
radiant/modules/entities.lua:345: in function ‘distance_between’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:166: in function ‘_apply_aoe_damage’
…h/ai/actions/combat/attack_melee_adjacent_action.lua:137: in function 'fn’
radiant/controllers/nonpersistent_timer.lua:56: in function 'fire’
radiant/controllers/time_tracker_controller.lua:82: in function <radiant/controllers/time_tracker_controller.lua:82>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/controllers/time_tracker_controller.lua:82: in function ‘set_now’
…hearth/services/server/calendar/calendar_service.lua:379: in function ‘_on_event_loop’
…hearth/services/server/calendar/calendar_service.lua:37: in function 'instance’
radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:200: in function 'trigger’
radiant/modules/events.lua:269: in function '_trigger_gameloop’
radiant/modules/events.lua:320: in function '_update’
radiant/server.lua:62: in function <radiant/server.lua:58>

Steps to reproduce:

  1. Don’'t know

Expected Results:

Actual Results:

Notes:

Attachments:
http://www.sendbox.fr/41f3d191319b0c94/1460595408482.zip
http://www.sendbox.fr/49df44e38406ed4e/stonehearth.log

Version Number and Mods in use:
Alpha 18 build 2924 no mods

System Information:
Windows 10 Pro 64 bits
8Gb ram
CPU I5
Graphic Card Intel


#2

thinks its about a fire arrow…
from your post:
=> in function ‘fire’ => in function ‘applyaoe_damage’ => in function ‘distance_between’


#3

Yes it is the correct name problem with fire arrow i was too lazy at this time to look with my eyes lol


#4

I had this in alpha 8, try going into settings and lowering the light thing. Don’t reamember what it was called😀


#5

I always put all settings at lowest i have 2 computers one with Intel Intel I5 and another one with Intel Dual-Core and i know i’m stuck if i put all settings by defautl :wink:
The Alpha 15 was a real buff for my old one but i really prefer to play with Intel I5 and learning to mod with my old fatty computer;)