Swamp Biome Mod 🐸 (Big mushrooms)


#101

still waiting for update… :frowning:


#102

Bruno isn’t paid for this and he has many mods that he has already updated. Patience.


#104

patch_notes_button Mod Updated

For Alpha 23!
A23 compatibility patch and new mushrooms.

Download:
:up: At the first post. :up:

Changes:

  • Updated mushroom:
    screenshot%202018_02_14__12_26_55
    Replacing the old white mushrooms.

Bugs:

  • Loading a a22.5 save will throw errors from the missing white mushrooms. This should happen only at the first load.

Future plans:

  • The core biome can be considered complete. Though small changes will keep happening as we tailor it, mainly with the Firefly Clan progress.
  • The Firefly Clan proved to be very hard to do.
    The main delays are the building templates that are waiting for the new building in a24
    Their job tree completely different from hearthlings
    Lack of animations which prompted us to create our own model based of hearthlings rigs to be able to reuse their animations.

I hope you all like it and have fun!


#105


new problem… how i can run this mod?.. help DD:


#106

Looks like the .smod doesn’t have a root folder. Quickest way for you to fix it without too much trouble would be to either unzip it by renaming it to a .zip and extracting into a directory called swamp goblins (which should be default behavior for most extractors. If you want you can then re-adding it to an archive to include that directory, change the file extension back to .smod and then delete the swamp goblin directory. Either way should work. Or the third option would be to wait for @BrunoSupremo to repackage the .smod.

NOTE * the folder should be swamp_goblins


#107

Fixed, sorry for the mistake guys, I tried a new way to build the mod without tested it first, it didn’t worked.


#108


It work right now in new version… but where my UI? @@

UPDATE: it not work. time in game has been stoped.

I take a lot of time to get to the map… (than 5m)… It has existed since previous versions. I only load this mod.


#109

Odd. It worked for me. Did you add it in later? Not sure but I believe it is a biome and kingdom mod so nothing else from an older save would be new.


#110

The problem appears when i try load my save (both old and new version)


#111

So just a few quick questions. Are you just seeing a black screen when loading and it takes forever to get to the Radiant splash? If that is the case it is probably either a busted download or a very old mod in your mods directory. I would recommend looking in the mods directory and redownloading any mods that you downloaded recently. I noticed having frostfeast simply in the mods directory caused me this issue. I can say that @BrunoSupremo’s mod does not have this issue unless like I stated the download itself got corrupted but redownloading should fix that issue.


#112

Added the mod, but I’m getting the ‘Invalid Manifest’ notice when I try to activate the mod


#113

Try downloading it again. should be fixed. The old version had this problem.

DuckyLuckVN, you probably just had the “no-ui” bug. Press f5 to reload it. This is not related to the mod, more about performance.


#114

when u load my save… it’s work with u??


#115

No. But you have like 10 or so mods in it, some changing a lot of game behaviors. Hard to know what happened.


#116

A small hint on whats comming in the future…


#117

Sorry, does this mod work with Latsets/Rickety? - i would suppose not? Concidering its not in the workshop? cheers


#118

There is a big change in a24 related to water that makes the biome take around 15 minutes to generate… If that does not bother you, it should work fine.
A fix for this plus other changes will come later.


#119

Just noticed (dont know if just me - i have a beefey system - well, beefey for SH) that this mod (i am using in alpha 23 - stable - as reccomended) at night time i have stop-lag where the game plays great for about 30 sec, freezes for a nano sec… and then so on until morning)

NOTE - when morning comes the game is once more silky smooth - is this a know issue with the mod itself? or is something going wrong my side?

Thanks


#120

Probably the mod. There is too much going on it. The next release will be better optimized, with less objects and less effects (the weather system basically replaces the fog I did here, and it is better)


#121

@Wouter_Sikkema you where wondering if there where other goblin projects in the works? Take a look here, there is of course alot more going on behind the scenes, but some things can be seen in this thread.

Thank you :slight_smile: