Sound fall-off failur when moding your own sound effects (sound must be mono)

So Drotten and I was coding the TMC(The Mythical Creatures)

Drotten was coding in some sound effects that we managed to get and edit, and we came to a problem.

the sound effects wouldn’t become any quieter as the camera went far away despite the code being like the image below

it seems to be some sort of moding bug considering that the other sounds in the original game doesn’t suffer from the same issue

it would help if you pointed out anything!

1 Like

Can you try with the values from another effect?
For example, the sound when you approach a talisman on a stockpile, it has these values:

"sound": {
     "type": "sound_effect",
     "loop" : true,
     "start_time": 10,
     "min_distance": 20,
     "falloff" : 30,
     "volume": 50,
     "track" : "stonehearth:sounds:twinkle"

Just to see if it works (you could try them with your “track” property). Maybe some of your values are not valid and the game doesn’t recognize them. Or they are wrong and should be different to achieve what you want. Try beginning with default values like these ones, and modify one property each time, to get them right and see which one fails.

I haven’t used the falloff property, so I’m not sure what is its value range, but I hope this helps both of you to debug the effect :sweat_smile:

Drotten probably tried out a lot of variations
And i think they all didn’t work

But sure, i guess we can try it out

So, playing around with falloff and min_distance really does no difference… until I changed the track to use. When using Stonehearth’s own sounds it works perfectly but with our own the sound can be heard no matter the distance between the camera and the entity.

It leads me to believe that the sound assets has to be created with some speicific properties, kind of how the .qb files must be exported in a specific way. Maybe @Doug can shed some light on this?

EDIT: I found the root of the issue! The track has to be mono, whilst we had it as stereo. Re-exporting it as mono instead solved it.


Perfect! Thanks for reporting back :smiley:


Good to know for future modding! Thanks for figuring this out