Slow UI in r923

Thanks i report back once i have tried a bit with other security software such as AVG and Avast. Which one are you using?

Windows defender.

i tried with AVG and i tried moving game from Samsung 840 SSD to Samsung 860 SSD with same results.

For fun since i keep old build of this game on my PC to return to i tried an older version and clicking objects on that one is instant not sure how it degraded so much in performance :S i also have 170 fps compared to new client that has 60-70 >_<

Older version is named develop-2955 :slight_smile:
sometimes i almost wanna play these old versions because of how bad performance has taken a turn

:disappointed_relieved: sad to hear. I can’t seem to reproduce this at all, for me it’s instant.
I have no idea what could be causing this.

What’s your PC setup and are you also on Windows 10?

Yes, Windows 10. At home I have an i5 at 3.2 GHz, 8GB RAM, and GeForce GTX 750 Ti.

On this other laptop (W10 too) I do have an SSD, an i7, much more RAM and the graphic card is a bit worse. It’s likely my graphic drivers are not up-to-date, though :slightly_frowning_face:

I normally play windowed mode and with vsync enabled.

If we disregard the lower FPS, the issue you mention is slow UI, which I think either it’s caused in the UI process or perhaps something in the server/client communication is going wrong. Does it still happen if you run the game with Steam logged off? Or run the game in 32bit?

tried both did not change anything for me.
you can see that the “board” loads up first then text pops in after its really weird

@Banto I moved the conversation to a new thread.

noticed after :slight_smile:

also im gonna try few things even tho i dont think they will help.
Clean Stonehearth install without any saved templates or save files 5GB or screenshots or mods.

made a back up tho so i wont lose my Youtube Town >_<

Interesting i just did this clean install and for me atm it’s near instant
i wonder if there is some sort of issues with having to many save files or saved templates that makes it slow

Maybe something went wrong when it updated :woman_shrugging:

I can tell I have too many savefiles in this computer from Discourse bugs :joy:
But that only makes the Save/Load UI be a bit slow when refreshing.

As for saved templates I don’t know. How many do you have? I could try enabling a ton of template mods from the workshop :thinking:

Not sure i will have to check there might even be some old templates in there from before the new building system was added. Says 464 files i guess divide it by two because half is the images :smiley:
I wonder if keeping some save files in there inside of Compressed Winrar files can cause issues or not tho because i see i have a few ones there i have that inside my saved_games folder also and inside building template folder

bild

Nah that shouldn’t cause issues, I also have leftover compressed folders in there :slightly_smiling_face:

I just added every single mod i had and its still near instant i will move onto adding my templates and then saves to pin point the cause :slight_smile:

I guess could just been some old messed up file breaking game for me before. Not sure if there is perhaps a file that would be worth for me to send to you like some log for the install that is slow or not

Added saves
did not cause any slow downs to this ui element

Okay slow downs are caused when i add back my saved templates

2 Likes

Not sure what to do about it tho if it’s specific templates causing this or if its the amounts of templates.
I really hope it’s not the amounts causing it because i dont feel like deleting and adding them back over and over is solution

If you split them in 2 groups, add one of them at a time, and check if it behaves the same it could hint to a faulty template (although if there are many, it’ll be harder to detect).

If it’s the same laggy behavior, you can try like, selecting a number of them (idk, 100, and if that’s not laggy add another 100, etc) to verify if there’s a specific amount that’s the threshold where it starts to become laggy.

Do you really don’t get anything suspicious in the stonehearth.log?

stonehearth.log (16.8 KB)

another one after a new game again
stonehearth.log (12.7 KB)

2 Likes

Not been able to pin point any specific templates tried split in half and stuff and remove all templates older than 2018 but same results :frowning:
I really hope this is not a game limitation because i want to have many houses like many others also

I really don’t get why this would even affect ui performance when not even touching the templates

Was this happening in the previous builds for you as well, or is it new?