[Res] [r156] Escape key generates error

resolved

#1

Any time I press the escape key (if it’s to close a menu or bring up the options menu), the following two errors pop up. I tried deleting all my saves and it had no effect.


Three errors while playing and can't load any game
#2

Confirmed on initial world gen. On reload, the error did not appear.


#3

can confirm as well… [tagged]


#4

I started the game, placed the banner and hit Esc to save because I liked the location. These errors popped up, but the Esc menu didn’t.

I made a stockpile and tried again, and the errors popped up again, but this time the menu did appear.

Perhaps it was just the timing. I’ll try to reproduce, although the important issue here is those errors.


#5

I can confirm the escape key generating error repeatedly, despite reload and restart computer.

I fixed it by removing the “Furniture expansion plus” mod I had at the time. Not sure if that’s coincidence, but I installed the mod, and after realizing it doesn’t currently work, I got lazy and didn’t bother to remove it 'cause it was doing nothing. I then made a new game, draw some floor plan, cancelled the building, and since then every time I press escape key the two error boxes appeared… until I removed the mod and started a new game.


(r162) Quick Start only starts in peace mode
#6

Build 162 no mods. The ONLY time I get these errors is when I enter a normal game and pick my spot. If I use quick start I get no errors.


#7

This appears to be resolved in r166.