Remove Building Bug

Removing building button removes one section of wall at a time.

Designing a building then pause and remove the building. Instead of deleting the whole template it will remove one column or one wall section from the template. Repeatedly using the remove button will delete section after section.

Steps to reproduce:

  1. Design new building with grow walls or wall tool.
  2. Use remove building button before construction begins.
  3. Find the missing part, or repeat until you have half a building remaining.

Expected Results:
Entire template removed

Actual Results:
Only part of the template is removed


Version Number and Mods in use:
Unstable 2786

System Information:


i totally forgot to report this yesterday after i ran into it :fearful:

but i can confirm that this is the case, here’s a picture,


i have a similar problema that i can’t delete almost anything from a template


Definitely experiencing this one, twice now trying to remove a template / house that got bugged out. One was probably my fault trying to build it on a cliff edge and the scaffolding got messed up - hearthlings got confused and refused to finish it but I could not deconstruct it. Second time was a completely normal, nothing weird changed blueprint of the default house for two… got the flat roof bug and I could not deconstruct it either.

1 Like

I believe I have the same glitch being described here. Made a save purely to test out new features that I haven’t tried yet (hence the basic set up, don’t judge me). Had a house that wouldn’t finish building (I believe this bug is already acknowledged), more specifically the “Cottage for two”, tried de-constructing it, was left with a floor, two columns a wall, some scaffolding and a ladder, couldn’t get it any further.
Save is here:
Building Deconstruction (7.2 MB)

Anyone encounter this recently?

all the time :frowning:

EDIT: Apologies for the Bump, realised too late

no worry’s about the bump, though it is worrisome that this is still happening…just want to double check, what version # are you playing?

Due to the removal of the…well…removal tool in the game for A17, going to move this report to #no_longer_applicable. When the feature is re-implemented, will see what to do with this then.


Just re-read the Original post and realised my problem was different. Apologies. I’ll post it in the right place.
Version 0.16.0 (release 559) x64 build. - Hope that answers your questions.