[r151] GUI Unresponsive, Saw Duplication (fix: remove candledark)


#1

Summary
Started new world, promoted one character to Carpenter and character glitches out while producing carpenter saws. GUI becomes unresponsive.

Steps to Reproduce

  1. Begin new world and collect resources
  2. Promote a worker to carpenter

Expected Results
The worker promotes to a carpenter class.

Actual Results
The worker strips naked and starts spitting out carpenter saws… no joke.

As you can see, I experienced this once and promptly tried a second time to make sure it was no aberration. The same things happened in my second world attempt. Nothing special done… just trying to promote a carpenter. I thought about posting a save, but as the GUI became unresponsive I couldn’t save. Pressing Esc did nothing. It follows that I’m not sure if the job change was even carried out.

EDIT
Tried a third time, with the promotion being the first thing done, no resource collecting, no stockpiles, still happens. Also perhaps the GUI isn’t completely responsive but definitely is lagged and Esc wasn’t pulling up the menu.


#2

Thanks for posting this bug! It happens because you have candledark.smod in your mods folder, and this is causing issues with Alpha6. Please try removing candledark, and see if that fixes the problem.


#3

Nice! No more issues on that front, can finally start playing :smiley: Thanks for the quick reply.


#4

Oh, it freaked me out too, let me tell you. Infinite saws!