R-335: Crafters' workshops "stutter" when they start working on an item

When I build a workshop, I give orders to make my crafters make stuff. (Naturally.) However, sometimes I want to give them many orders at once. For example, I like to make my carpenters keep a small supply of building materials (doors, chairs, lanterns, etc.) So, to get it all done early, I give as many of those “keep X in supply” orders as possible at the very beginning. (Of course, some orders have to wait until they level up, etc.) However, at some point when I’m assigning these orders, the workbench “stutters”, and shifts the focus to the default item for that crafter.

Steps to reproduce:

  1. Promote a Hearthling to be a crafter with a workbench (e.g. Carpenter).
  2. Build the workshop.
  3. (Optional, but helps for effect:) Make a stockpile of what the crafter uses (e.g. wood) far away from the workshop (to make time elapse while they fetch the item).
  4. Wait for (or order) the crafter to do something that takes them away from the bench and stockpile.
  5. While they’re away, select an item to craft (e.g. Mean Bed).
  6. While the crafter is walking towards their workshop, click on another item to create (e.g. Wooden Door).
  7. Wait for the crafter to start crafting the item.

Expected Results:
The selected item in the workshop (in the example above, Wooden Door) stays selected, along with any quantities entered in the boxes.

Actual Results:
The crafter automatically defaults to their default item (for carpenter, this is the Farmer’s Hoe), and clears all quantities to 1.

Notes: This happens every time they start crafting an item, at the instant (well, close enough to the instant) that they do the first “work” on the object. This also happens to every crafter with a workbench (so far, carpenter, mason, weaver, and blacksmith).

Versions and Mods:
I’m running Stonehearth r-335, 64-bit, with Zulser mod (Release 3-a).

1 Like


everytime you use a workshop it will cancel your settings when an items was produce and jumps back to the first item.


  1. Set items to produce.
  2. Try to set another item to produce (dont set it to the tasklist) and wait that in the background an item will be produce

-> it will cancel your settings and give you the startscreen ^^

I’m pretty sure this is the same bug listed here. Thanks for the confirmation that it’s still happening!

ahhh under stutter i havent search ^^ THX xD

@SteveAdamo please merge it :wink:

no love for the new admin :wink:


sry my sweety :smiley: thanks for the merging :smiley:


This appears to be fixed as of Alpha 10.5-10. @Albert, @sdee, was this fixed intentionally, or is it just a fluke that this is working? (It doesn’t appear to be in any release notes).

Yes, fixed as a side effect from another bug. Thanks for checking!