Pretty small bug, but: archer won't go on patrol


#1

Summary: currently playing as the Northern Alliance, tried to check one of my old building models and the game had a crash report while still working. Nothing unusual on the crash report itself, considering the game was still working the same way as before; unfortunately, it caused the archer not to go on patrol after that.

Steps to reproduce:

  1. Make heartling into archer after checking an old template
  2. Send him to patrol

Expected Results: game functioning as usual, archer patrolling*

Actual Results: game working as usual, but archer won’t go on patrol at all

Notes: I use a few mods that are a bit unrelated I think, but they may have something to do that I’m not aware (the template was modless).

Version Number and Mods in use: Armis maximus, Stonehearth Cafe, Home Sweet Home, Settlement Decor. Current version is 1.0.0.9 according to Windows while checking the file itself

System Information: Intel Core i5-3317U 1.70GHz, 8 GB of RAM. Intel HD Graphics 4000. Not very strong, but strong enough to support the game alright.


#2

Hey @Cupcake, belated welcome to the forum! :slightly_smiling_face:

What do you mean by “crash report”? Do you mean that a window with an error message popped up in the game?

If that’s the case, do you have a screenshot of it? If you haven’t restarted the game after that happened, could you right click Stonehearth in your Steam library, click on Properties, Local files, Browse local files? It will open a folder which contains a text file called stonehearth.log. Could you upload it? It might still have the error message in it.

If you have already restarted the game, does the archer still not patrol? Do you have any stockpile or farm that he can walk to? Is he perhaps busy hunting wild animals? Did you promote him after the error? If not, was he patrolling before the error?

Without seeing the error message or the savefile it’s difficult to determine why he doesn’t patrol. There should be no relationship between the building and the archer, but who knows.


#3

oh, yeah, forgot the word for a moment, sorry :stuck_out_tongue:
Unfortunately I didn’t screenshot it, and I know it was a bad idea not to do so, but I didn’t think it’d affect my archer.
I did restart the game, but he wasn’t patrolling as well. I can still send him to attack and hunt, but he’s just idling when not being sent to any of those. I did promote him after the error, and that may be what caused him to be like that I think. Might try demoting and promoting him again to see if it works though.

stonehearth.log (5.6 KB)
Here’s the .log file. Thanks for the reply!


#4

Oh! I can agree something similar happened to me. We got attacked while charging crystals for the bunfolk and I called my archer back to arms after being a worker for quite some time. The archer refused to follow orders of where to go but did attack enemies. After the fight, he did go on patrol - refreshed from the taste of blood. RC in Glacier.


#5

The log doesn’t have the error, sadly.

Could you upload the savefile where he isn’t patrolling?

  1. Find the save folder for the savefile you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
    1. Right click the folder (should be a long set of numbers).
    2. Left click on Send to in the menu that appears.
    3. Left click on `Compressed (Zipped) folder).
    4. (Optional) Rename the folder to something different than the default set of numbers.
  3. Upload the save.
  4. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  5. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

#6

Sure! Tried demoting and promoting him again already, btw, and same thing. I had checked the log file myself, but thought it may have been just me not seeing the error in the file since I’m not exactly versed into this sort of thing, but oh well lol

buggy boi.rar (3.0 MB)

Here it is. I started it recently, but considering that the bug is pretty small, I’m still playing it normally since I can send the archer to defend the town and hunt.


#7

So, update: after a while, the archer somehow started patrolling again. After demoting and repromoting him, a bunch of stonelings came to town and I put him to battle them, so, after that, seems like he went back to normal.
Guess it was pretty similar to @Amnaa’s bug


#8

@Cupcake, I don’t see any patrollable item in your savefile.

As soon as I made a stockpile, the archer started to patrol.

Combat units will patrol stockpiles, farms, and certain types of storage. If they don’t have anything to patrol to, they will stay idle.


#9

This is something I’ve seen a lot in, especially, my bigger cities.
Basically, whenever I play on the higher speeds of the game (think double or tripple), then very often my soldiers either are very delayed in acknowliging their orders, or they simply ignore it.

Though, when I then go to the normal speed of the game, and either give them their orders again or wait for them to finish whatever they are doing, so they look for new stuff to do, it seems to fix it.
Think it may have something to do with the AI not picking these orders up well at the higher speeds


#10

Pathfinding is one of the most expensive AI tasks to compute, and military orders often involve pathfinding across a long distance, so this makes sense.