[MOD] Locks of Many Colours:Version 4 now available! [A16]

Yes that is ok :wink: i will make a new Screenshot or you can use them from Our pm xD

1 Like

There are some very interesting possibilities with Version 3!

I believe that is the gentleman’s haircut and the pharoah beard, for this slightly creepy final result!

4 Likes

Thats correct xD because with the New way there is no Definition which is compared xD I can reado that but i think now there are more variants and like it xD

Heyho!

Little question for all: At the moment we have 3 male: 1 White 2. Brown 3. Black. At the moment only the white male gets beards. So the question for you is:

Do you want beards also for male 2 and 3?

  • Yes
  • No

0 voters

2 Likes

This should be updated for Alpha 14, it’s actually a nice change to see these bright hairstyles.

2 Likes

we’re currently working on updating it :smile:

well @Wiese2007 and @Kittyodoom are, im just sitting there watching them do all the work :stuck_out_tongue:

3 Likes

v3 is for a14 … at the moment we are working on an update thats correct but its works for a14 just now :stuck_out_tongue_winking_eye:

2 Likes

New Update for Version3 with some bugfixes AND 1 change to carpenter outfits

4 Likes

and again a little update - now with more stuff and a new colormap (powered by my daughter xD)

5 Likes

Hey, um, @Wiese2007?

Are they supposed to do this?

Because, uh, she DID have hair…

1 Like

As did he:

1 Like

Looks like those 2 need to have that flag switched. The one for hair showing.

hmmmm ok that should happen … prob is that i must name the layer hat … and must make it not transparent but then it kicks the hair -.-

i could give the layer a complete new name but then i must change the position of the layer to wide left so that it goes on the head xD -> ok this doesnt work because its not added to the skelett -.-

edit: looks like i must remove this … googles are not supported in outfits xD

2 Likes

But doesn’t the armor circlet do roughly the same thing you are trying to do with the goggles? keep the hair showing although it is marked as such. Thought it would just overwrite the voxels. Maybe using the circlet as a basis to get it to work might help, maybe?

googles as stand alone are not the issue - there already some working in the mod :wink: but within an outfit thats not possible xD

1 Like

guess it only works for default outfits then. At least from what they presented the bonnets the farmers wear and their outfits do the same, although they are default and simply have the bonnet and hat marked to as a hat/helm, but goes only with the default farmer clothing. The flag I would have though would be simply the same that is used to show/hide the hat portion of the hair.

So not possible to make anything beyond default then outfits… oh well, at least as you say there are ones separate. :slight_smile:

1 Like

Why? There might be a case where it’s not working for you, but for example I overwrote the upgraded worker outfit so it does have glasses and it works (super quick test, so misplaced glasses):

I’m not sure what would happen if they wore hats at the same time, but as far as I remember, for hats the relevant matrices are “hat” and “hair”, not “head”. It should work fine. (Or you could always put them into another matrix xD )

4 Likes

ok and how has you named the matrix fo the glasses? AND are the glass added to the skelett? i can also add them but then they are not added to the head and while he breath the glasses goes in the head :wink:

with the name head its overwrite the head - with hat it remove the upper part of the hair and with hair its just an entitie which is not added to the skelett xD

It depends on what are you trying to do. Are you placing the glasses on the “clothing” layer too?

I named the matrix “head” for the glasses. If you’re using the equipment component there are two options (“merge_with_model” or “attach_to_bone”) but it’s not necessary here, we’re using the clothing tech.

Here’s my test mod so you can check the qb and the json (I only modified the json so that it points to my qb files):
glassesoutfit.zip (17.0 KB)

Edit: now I see that Tom had the same problem (I’m still catching up with the streams). It’s true that it might give problems. I remember now that there are many female outfits that need to have transparent set to false, which might make the head disappear :disappointed_relieved:

Still, there should be some other way…

5 Likes

Sooo little update to make i compatible with Homf xD

3 Likes