[Mod] (A20) The Bastioneers! More Dangerous (and Mod-Friendly) Than Ever! Help me test for A20!


#161

Okay, what should be placed in the mod folder then? The unzipped content of the .smod?


#162

I found the error and patched it, thanks for the info :slight_smile:


#163

Yeah, I recommend that, Im still looking into the smod thing


#164

Sooo… I opened again, tried the same thing and… well…

develop-3010 (x64)(M)
…rth/services/server/game_master/controllers/node.lua:47: invalid nodelist passed to create_nodelist
stack traceback:
[C]: ?
[C]: in function ‘assert’
…rth/services/server/game_master/controllers/node.lua:47: in function ‘_create_nodelist’
…/services/server/game_master/game_master_service.lua:143: in function '_start_campaign’
bastioneers/bastioneers_server.lua:29: in function ‘start’
…vices/server/game_creation/game_creation_service.lua:270: in function <…vices/server/game_creation/game_creation_service.lua:268>

2:
develop-3010 (x64)(M)
c++ exception: lua runtime error
stack traceback:

I might be stupid, but it looks like this is quite the same bug to me.


#165

76 bugs in the code of the mod, 76 bugs in the code!
Take one down, patch it around, 912,638 bugs in the code of the mod!


#166

I’m playing the latet version as well and I get the issue about the spawn


#167

Try unzipping the mod files to your mods folder


#168

Ok, I’ve been playing for a while now and love the Bationeers. Here is one error message that popped up when building a naval stone:

develop-3013 (x64)(M)
stonehearth/components/storage/storage_component.lua:188: attempt to index local ‘item’ (a nil value)
stack traceback:
stonehearth/components/storage/storage_component.lua:188: in function 'add_item’
stonehearth/components/crafter/crafter_component.lua:168: in function '?'
stonehearth/ai/actions/call_method.lua:37: in function <stonehearth/ai/actions/call_method.lua:26>
[C]: ?
[C]: ?
[C]: ?
[C]: ?
[C]: in function ‘run’
…tonehearth/services/server/tasks/run_task_action.lua:143: in function <…tonehearth/services/server/tasks/run_task_action.lua:141>
[C]: ?
[C]: ?

[C]: in function 'run’
stonehearth/components/ai/ai_component.lua:541: in function <stonehearth/components/ai/ai_component.lua:525>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
stonehearth/components/ai/ai_component.lua:525: in function '_thread_main’
stonehearth/services/server/threads/thread.lua:249: in function <stonehearth/services/server/threads/thread.lua:246>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
stonehearth/services/server/threads/thread.lua:246: in function 'f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>


#169

Furthermore I believe that your makeshift stone armour lacks a “inventory class”. It will not be moved to chests, even if they have armour enabled.


#170

Sure about that? I’m storing my whole inventory in stonechests including some stone armours an its working. Note, that I’m playing the version befor those two or three hotfixes this week.


#171

Hm… Do you start with all filters enabled or disabled, by default? I have them all disabled by default, and even turning all on, apart from the food ones, stone armour doesn’t get collected.


#172

Ok, my filters are enabled by default. They were stored in a storage are first and later when I deleted it they were stored in chests.


#173

I found a bug you should be aware of, idk if others found this or not, but on a temperate hardmode ascendancy it shows the bastioneer guy instead of the normal guy


#174

I had to google to find the github link; the one at the top of the post is an adf.ly link and I’ll be damned if I’m clicking that. =/ Please fix asap, that’s really not cool.


#175

It’s not cool to view an ad before downloading a mod someone worked hard on?


#176

Love this race and play style. Fav thus far.


#177

Not when clicking the “continue to site” button (I run ublock for the exact
reason of avoiding malicious ads) shoots me to a hijacker/malware site. =/
I have no problem with ads, but that particular site made me angry.


#178

Update 0.6 just went live! I’ve made the mod more stable and compatible with other mods, and playing as vanilla races with Bastioneers installed. Let me know if there’s a compatibility issue!

Gameplay Update: New class! The Refineer! You’ll notice that while playing the Bastioneers, you acquire much more stone and ore resources, well this is no good! You’ll be demolished because your net worth skyrockets, well now you need to refine resources to craft and build!

The trapper is now a non-patrolling combat class! Because you need some defense early on, so trappers are highly valuable!

Many more balance and gameplay improvements! I’m always polishing up the little gems.


#179

Can confirm what Suchevane’s been saying, as of right now Adfly’s redirecting to malware. So your mod’s currently inaccessible for those of us who like having working computers.


#180

5x tested and cant find any issues with the adf.ly link - just some advert but nothing suspicious ^^