[Mod] (A20) The Bastioneers! More Dangerous (and Mod-Friendly) Than Ever! Help me test for A20!


#141

well the first one worked but the second one didn’t maybe there is a random element in it, I placed them both on the same spot outside.
My 3rd one worked, maybe it is random or there might be some hidden wealth constraints on it.


#142

Found another reason for the disappearence of softstone: pets. Those little buggers got into my mine and ate the softstone because my mushrooms are stored in chests.


#143

Did you guys happen to reload the game while the stones were growing?


#144

I am having a hard time getting the natal stone to produce more neers. I made two and they just disappeared. I wasn’t watching them but I did see them get placed. And still a villager count of 7. So I made a 3rd one and made sure to not move at all after it was placed. They set it down and a short while later the mason picked it up, took it to his table, and smashed it to make a wall lantern :confused: In the following picture the natal stone was placed two blocks to the left of the fireplace.


#145

Slight issue, having this mod installed cases the vanilla two races to never generate new hearthlings, the ‘story’ element at the start also runs for the vanilla races. Obviously I can just remove the mod while playing another race but thought it was worth noting.

I’m running this on the latest branch (3002), but I experienced this on the normal branch on Steam too.


#146

I frequently reloaded the game due to engine errors that seemed to occur when I was mining a large area and had the game on x3 speed, something to do with mining drops, I assumed it was because I had it on x3 speed as it wouldn’t do it when I was on normal speed. But yeah I reloaded the game quite a lot.


#147

You just discovered where the missing stones were going! I posted a hotfix for this bug and other bugs :slight_smile:


#148

I got this in the hotfix as well, I think. Thanks for the notice :slight_smile:


#149

hey, I think the hotfix ain’t working, I’m getting the issue with spawn


#150

Hey guys, I’ve been trying to get the bastioneers mod to work, but when the bationeers.smod is in my mod folder, the game won’t start at all (I’m running the last stable build, as I think this is for A17, and my only other mod is Anorien Biome)

I just went to the google drive and pressed “download”. Then moved the file into the mod folder. Anything else I should have done?


#151

just checked, and it indeed is crashing. @Wharp, looking at my .log file after it crashes, there appears to be a missing } in the en.json


#152

Same issue as in you don’t get daily updates as bastioneers or for all races?


#153

I released another hotfix. Its tested and working so make sure you get the latest version


#154

In good news: The game doesn’t crash immediately. The bad news: It crashes immediately after immediately is over. I get a message: Assertion faled.


#155

Black humor at its peak :). Could it be those two hotfixes? I’m running the game on v3010 fine with the mod version before those.


#156

Well, surprisingly, after switching to the latest branch, the game does not crash anymore. So perhaps the mod description should state it is made for the latest branch? (Which is awesome, by the way)


#157

Uh oh, looks like the new mixin property might be causing new issues, I need to look into this


#158

I’m noticing that things don’t load properly when you use the smod but when its decompressed it works right.
EDIT: it could be my hacky way of loading a mod within a mod… :frowning: This makes me sad


#159

I’m noticing that when playing with the .smod, it doesn’t load things the same way as when its decompressed


#160

Well… although the game starts as expected, I cannot place the town banner down. I get two errors:
develop-3010 (x64)(M)
…rth/services/server/game_master/controllers/node.lua:47: invalid nodelist passed to create_nodelist
stack traceback:
[C]: ?
[C]: in function ‘assert’
…rth/services/server/game_master/controllers/node.lua:47: in function ‘_create_nodelist’
…/services/server/game_master/game_master_service.lua:143: in function '_start_campaign’
bastioneers/bastioneers_server.lua:29: in function ‘start’
…vices/server/game_creation/game_creation_service.lua:270: in function <…vices/server/game_creation/game_creation_service.lua:268>

2:
develop-3010 (x64)(M)
c++ exception: lua runtime error
stack traceback:

This is not connected to Anorien Biome, as I tried in a normal tempest one too.