I got these weird floating poles and I can't remove them

Summary: I was building a fishing hut and I didn’t have a carpenter yet, so I just let it be unfinished and then out of nowhere they started working on it, the top of the hut went red so I destroyed it, and now I got this thing.

Steps to reproduce:

  1. I don’t actually know what happened here

Expected Results:

Actual Results:

**Notes:**I have tried to destroy and that seems to be about the only command that COULD fix it, but it hasn’t done anything, I’m out of options and the last save i have before this is about 6 days ago


Version Number and Mods in use: Version: 1.0 with hotfix 2, 23 mods (most of these are just templates)

System Information: I7 4770k, RX560B, 24GB DDR3 RAM, Windows 10
Edit for comma

Is it possible to select those? They are building voxels or items?

1 Like

@BrunoSupremo I can select them, yet it has nothing on them

Edit: I think they are from the building

Have you tried saving and reloading? Maybe they’re a visual artifact. Can you place a building where they are?

I tested here and got to reproduce the bug. When you destroy a building that has a fishing dock on it, it will leave the dock legs in the world.
To work around this, you can select them, press ctrl+c to open a command console, then type destroy. It will remove that from the game.
I’m going to fix this bug so it does no happen anymore later on.


thanks @BrunoSupremo you really are a legend