Game says it will launch then doesnt

Summary: steam says launching yet it never launches

Expected Results:
to launch
Actual Results:
never even shows up as running on my task manager
i have uninstalled cleared filed reinstalled i even went so far as ti reset my 1 yr old laptop and fully update it and make sure all drivers were up to date then reinstall the game and yet still nothing

Version Number and Mods in use:
im not sure version number but whatever latest one steam offers
System Information: processor intel® pentium® silver n5000 cpu @ 1.10ghz
ram 4gb
64bit op
windows 10 latest version
also anti adware is disabled

i’ve read through about 20 topics all the way from 2015 about not launching none fixed my issue someone please tell me what i can do i thought this game was adorable id rather play it then get a refund

also i had posted this in bugs and somehow clicked delete so i reposted it here. sorry for double posting

It may be your hardware not meeting minimum specs

would my processor lacking cause it to simply not launch? ive ran plenty of very hardy games some lagged ive had fps issues but never had a issue of a game simply never starting. it doesnt even crash it just never starts. if that is the case ill try a different computer in a few months, i thought about getting my money back but i simply think this game is too cute to really do that so even if i cant play it right away ill hold onto it, but i really do wish it would start. even laggy would be better than just not starting at all ):

It’s strange that you’re able to start other games.
Because you “only” have 4gb Ram, so I’d assume you simply have no Ram left to start any games.
Win10 already takes like 3gb Ram, and with steam open and maybe some sort of messanger like discord … My first guess would’ve been the same as nightlancers. Simply the lack of Ram.

i recently wiped like full factory reset the computer so i was hoping that would help, i mean i can play sims 3 full eps installed and thats a really ram and cpu hardy game even on newer comps. i play banished no issues and minecraft online no issues i even can log into sea of thieves no issues. ive never experienced this and not im kinda worried about buying more games until i get a new comp. i mean banished itself wants more than i have it was 2 when i have 1.10 processing power and it never lags even when full of mods. i just dont get why i dont even get it to launch. like if the game went to main menu i started a game up loaded forever and crashed id understand but not launching is just so odd

also with that said sims 3 nor any other games are installed since the reset i was trying to make room but it didnt help

do you think ram is the issue and not my processor? if its ram i actually think in have portable ram usb boosters i can plug in and install the drivers for. im not sure if they work for newer comps but i bought them back in like 2000 for a desk top and they worked then lol

I have absolutely no clue whatsoever what could be happening there.
If you say that those games are running relatively smoothly, than there should be some problem with steam and launching the game itself.

It’s really … confusing, how only Stonehearth isn’t launching for you.
All I can tell you is, that you perhaps should google the problem or wait until you have your better pc.

If you have Discord, I’d recommend joining the ACE Server. A lot of the active Stonehearth community is on there and maybe some smart person can help you there.

okay thank you will do, yeah i msged steam and they were no help on their side they basically said uninstall and reinstall like i hadnt tried that lol ty

Does that laptop have a dedicated GPU (graphics card), or on-board graphics? I’ve had various games fail to launch/initialise on my laptop because the on-board graphics card won’t support the graphics tech they require, even though it theoretically should. Stonehearth is the kind of game that really requires a dedicated GPU, even though it doesn’t actually need a lot of graphical processing power the way it handles graphics does require the kind of tech that comes built-into a separate graphics card rather than on-board graphics.

On that note: even if you get the game up and running with that laptop, a 1.1ghz processor will struggle to keep up with even a tiny town – Stonehearth is much more reliant on the processor than even something like Minecraft. One really big thing you could do to help with that, though, is to use a “smaller world” mod – the Extra Map Options mod has one, plus a bunch of other awesome features, but you might want to go even smaller.

Those plug-in RAM boosters may well help too, but it’s worth pointing out that the way Stonehearth uses RAM caps the amount it can use to only a few gigs. That said, given how much RAM Win10 uses as a baseline + whatever else your computer has to run in the background, having an extra couple of gigs of RAM to be safe definitely sounds sensible. If it was some kind of “Out of Memory” error though, I’d expect you’d be getting an error pop-up. Which reminds me…

If you go to the game files (easiest option in case you’re not familiar: Steam library > right-click Stonehearth > properties > “local files” tab > browse local files) then you should see a log file (probably just a text file named “stonehearth”), and possibly a zip file named “crash” – they should have useful info to help diagnose the specific issues. Of course, you only get the crash file if the game actually starts and crashes… if it fails to initialise altogether, then there may not be any such files. But it’s worth a look – nothing is quite so helpful as when the game tells you exactly what’s going wrong hahaha! :merry:

That laptop does not have a dedicated gpu
A gpu wouldhave more than doubled the price

I have had this game for a while. I haven’t played in a few months but never really had a problem with launching until now. I know the game is abandonware at this point. If you can get a refund unless you bought it on sale I would do so and see if you can find a solution before you rebuy it. I just got it running not sure why it started working but it wasn’t launching then just did.