Game freezes when focusing

:slightly_frowning_face: I think your processor is on the border (the minimum for playing the game is 2.0GHz) but I don’t think that’s what’s causing it to freeze on focus, let’s ask @jamiltron if that’s the case or not.

You could also do a clean reinstall, if updating the drivers didn’t work:

  1. Launch Steam.
  2. Right-click Stonehearth and click Properties
  3. Click on the Local Files tab
  4. Click Browse Local Files...
  5. If you have saved games or templates to save, complete the following. Otherwise, skip to step 6 below.
  • For saved games, copy saved_games to another location, like your Desktop.
  • For templates, copy saved_objects to another location, like your Desktop.
  1. Go up one directory level to the common folder.
  2. Delete the Stonehearth folder.
  3. Close Windows Explorer and return to Steam.
  4. Right-click Stonehearth and click Uninstall...
  5. Once removed, right-click Stonehearth again and click Install Game...
  6. If you backed up saves or templates in step 5 above, do the following. Otherwise, skip to step 12.
  7. Right-click Stonehearth and click Properties
  8. Click on the Local Files tab
  9. Click Browse Local Files...
  10. Copy the backed up folders into Stonehearth folder.
  11. Close Windows Explorer.
  12. Launch Stonehearth
  13. Finally…
  • If this works, great! Please let us know so we can mark this as resolved.
  • If not, please upload your stonehearth.log from the game install directory (follow steps 2-4 if unsure how to access) to the Discourse so we can take a look.

Thanks, that can be the case, my processor has 1.80 GHz, but i followed every step, and runned the game, made up a world but the world selector (or generator) wouldn’t make a world up. I’ll place the stonehearth.log in here, but i am now waiting for like 10 minutes for a world to generate

stonehearth.log (6.9 KB)

1 Like

Hmm that’s weird. Does it happen every time? Did you click too fast to skip the embarkation screens until then?
There’s a UI error in your log, thanks for uploading it.

I think starting a new game should work fine. Are you still having troubles with the camera?

Yeah, the minimum specs for running the game includes a dual-core 2.0 Ghz and up processor.

1 Like

Yes, i probably clicked too fast. But the camera issue isnt fixed. Its a bit reduced, less time freezing but it still happens. I think its just my processor… good bye €18,- :persevere:

stonehearth.log (62.2 KB)