Fisher Job 🐟 + Archipelago Biome


That all sounds great! The only issue I have is the teleporting system you have in mind. you already said it’s not that great lol. I mean you can very easily just mine out stairs and have your hearthlings run there right through the water right now. now granted they move slower in water, and long distances mean chances of them starving, but it’s a risk I’m willing to take! but seriously it would be a nice enough jumping off point for proper sailing with your teleportation dock system.


A question that has probably been answered before, but I’m honestly too lazy to read all 212 responses :frowning: If I install Archipelago will I have access to Fisherman as a profession on other biomes? Like, for instance, if I play on the Anorien biome?


New class: Fisher

It will work in other biomes too! (Though with less features when outside the Archipelago)

Don’t even need to read through the responses, it’s in the initial post / description :slight_smile:

Speaking of which, the updates to this mod since I was last active look amazing, @BrunoSupremo!


So for some reason I can’t play this mod. It’s showing up on my mod list as an “Invalid Manifest”. What’s up with that? Is there a way for me to fix it?


… What’s a Stonehearth.log file?

I can list off the mods I have.


Here’s my mod list.

Yang decorations.

Yang armoury.

Terrain colors.

Better stockpiles.

Settlement decor.

Settlement decor bs.

Cook mod.

Cook mod bs.

Brewery mod.

Brewery mod bs.


More AWas.

Skyrim battle music.

Jomaxro doorway.

Patrol mod.

And Archipelago of course.

(Yes, I really love mods.)

I tried to find that file, but I don’t really know what I’m doing and couldn’t find it. You said something about a x86. I found a x64. It wasn’t in there though.


AWaS is “More Awesome Weapons and Stuff” I believe.

And I’m sorry, but I really don’t see this Stonehearth.log file. Don’t know what to tell ya. :woman_shrugging:


stonehearth.log is found within the main Stonehearth-folder; this is, one level above your mod-folder.
Make sure to un-hide file extensions unless you already have done this - un-hiding the extensions will display your file-names like cef.pak, crash_reporter.exe, libcef.lib, etc.

However, in this case, even if you do not un-hide file extensions, stonehearth.log should be somewhat easy to find - it is the only “regular” text-file within your main Stonehearth-folder. In my case, it is the 3rd of the files including “stonehearth” in their name.



Huh…I tried installing the mod and in game it says that the mod has an invalid manifest and wont load. Is my computer possibly corrupting the file during download? Or is there something else I should check on?


:warning: Bugged link :warning:

For some reason, the download name changed. Because of this, the game fails to load it.
I added a new link there that should work.

For the above problems, from Musicalocelot and Alexander_Harvey, I solved their problems via PM.

Meanwhile, because I feel bad for this and to post just something that is not really useful, here is a turtle shield, as suggested previously. I’m actually working in the campaign to reward that to the player right now, well not now that I havd to stop to fix all this problems :stuck_out_tongue:
It should be equivalent to a bronze shield, except you don’t need a blacksmith to get it :slight_smile: For footman level 2, with two defense.


Hey, I was just wondering how to get my fisher to dos stuff! I’m in the temperate biome with a fisher, I have a float thingy but when I try to place it in water, nobody goes to place it in it (probably because you can’t build in water :smiley: ) Please can someone guide me through using the fisher and getting him to fish :slight_smile:

I have solved the placing the fish spawning thing, but my fisher still won’t fish! Please help :slight_smile:


You need to build a ladder into the water & the water can’t be more than 3 blocks deep or the fish bobbers won’t work

Then once the fish spawn I’ve found you need to run the harvest tool over the area a couple of times then the fisher will auto fish


I have a ladder, with the fish bobber in the water. It is bobbing and spawning fish. However, my fisherman will not go and catch any!


Unless he can’t reach it or is busy doing other stuff, he should go catch the fish if you use the harvest tool and click and drag around the fish.
For Auryanna concern about it needing a specific water level, there is actually no problem, it can be any deep, but it appears that fish will sink into the ground when they first spawn, taking a few seconds to appear again.

If you can, send me your save file and I can check if there is anything wrong that I need to fix in the mod.


Ah I see - I had noticed when I had 4 deep it wasn’t showing any fish but 2 or 3 deep was - not a big deal for me :slight_smile:


thanks soo much! I didn’t realise you had to use the harvest thing! Time for some fish!


I have a question about this biome…

{whispers} Are…are there no bunny statures?!

Dredged from the Depths: The Isola Experiment

Good reminder! I need to increase their spawn, right now it is super rare… In my whole map I have only one, on the other side of my island…
I remember old versions I added those in rows, to look like moai statues. But it was causing bugs. I may revisit this idea.


Might also modify the bunny statues to fit the biome better :slight_smile:.
A little color scheme tweak for example.


or better yet, replace bunny statues with tiki totems