Error starting applicaiton


#1

Summary:

Fresh Installation 2018-02-25.
Immediately after pressing “Play” in steam - or atempting to start the EXE, get a windows popup stating:
"“
Error starting application:
boost::filesystem::weakly_canonical: Felaktig syntax för filnamn, katalognamn eller volymetikett.
”"
Pressing OK removes the popup and nothing else happens.

Stonehearth.log:
No logfile available as game likely does not get that far.

Attachments:

No crash dump created.

Versions and Mods:

[What version of Stonehearth are you playing? Have you installed any mods?]

System Information:

[Please list Windows version (7, 8, 8.1, 10), video card (e.g. GTX 780), and monitor type (laptop panel or external monitor)

Have you attempted basic troubleshooting steps here: http://discourse.stonehearth.net/t/crashing-on-start-read-this-updated-october-28/13297:

[Have you attempted all the steps detailed in linked post? Please do before posting!]

Notes:

Screenshot:
https://drive.google.com/open?id=1oZE_u1uwBmwF_DiEnu1IPPAb5YGQKLwX

[Any additional useful information]


#2

I also have this issue. Fresh install of Windows 10 Pro (build 17115) on a Ryzen 5 1600, 32GB RAM
Video: GTX970

No mods

I do not have any antivirus or whatever type software beyond the built-in Windows Defender thing.


#3

In case anybody cares, I think I have isolated the issue (for me, anyway).

I have my system set up to store games on a separate drive, with a drive dedicated to Steam mounted within this.

So, F:\ contains a bunch of random crap, and all my games are stored under F:\Games. Under this is another folder called Steam. This folder is actually empty, but I have a separate drive (without a drive letter) mapped to it.

image

Now, this hasn’t been a problem up until fairly recently. I can confirm that running Stonehearth with this setup has worked in the past, since I’ve been using this array for about two years. I can also confirm that this has worked on my current rig previously as well.

I know this is the issue because I just copied the Stonehearth game folder to my desktop and tried running it. it works fine from there. It also works fine from just F:\ as well.

– end part one –


#4

—part 2—

Now, since upgrading to Ryzen, I’ve had this issue with my motherboard where the two drives (coincidentally, the games ones) plugged into the AHCI ports are randomly not detected by the motherboard on boot.

This may or may not lead to this funky error coming from Windows:

image

So I think I’ll try swapping some drive cables around in my case to see if that makes a difference. Either way, I think I should get a new board.


#5

I did some digging as well and my findings support Unfunk’s description.
My main steam repository is located in a dedicated drive mapped as a folder.

Creating a new steam repository on a “regular” drive works just fine so this must be an issue with paths to folder-mounted-drives.


#6

I’m glad I’m not the only nutter that thinks this is a good idea, then!

I just swapped the cables around, and while I no longer get the “device cannot start” error in Windows (and of course, my motherboard is a douche about the AHCI drives still…), I still can’t run Stonehearth from the default folder.

@Tobias_Christianson, how long has this been going on for you? I don’t play games often enough to really notice when things change, and I’d just chalked this up to an alpha bug.